Unable to load update ugh.

Discussion in 'Apple Watch' started by FrancoRumors, May 19, 2015.

  1. FrancoRumors macrumors 6502

    FrancoRumors

    Joined:
    Jul 23, 2010
    #1
    My wifes phone went right to update and started downloading. She has a sport watch, I have the SS.

    My phone first said it was unable to connect to watch. I also have received unable to connect to internet errors. I tried hard resets on both phone and watch with no luck. I also unpaired and repaired the watch. When I go to the software update section of watch app it just says checking for update FOREVER. Anyone else experience this issue?

    The phone and watch are functioning completely normal except for software not being able to update..
     
  2. BrianNH macrumors member

    Joined:
    Apr 20, 2015
    #2
    Same here on my watch. Wife's is fine. Mine insists I'm not connected to the Internet, which obviously I am, it just craps out as soon as it finishes downloading. I have restarted both my phone and watch to no avail.


    This is pretty crappy if they haven't adequately tested the update.
     
  3. TreoRenegade macrumors regular

    Joined:
    Aug 7, 2008
    #3
    Don't recall where I saw this, but there's a precise dance involved in securing a smooth update. Watch must be
    1) at least 50% juiced
    2) connected to same WiFi network as iPhone
    3) and connected to charger

    Frankly, Apple has devolved into Windows-like imitation so frequently in recent years, that I've taken to researching before applying updates on any Apple product. Stumbled across the listed 3 steps while the update downloaded, but prior to install. Hence, no hassles.
     
  4. BrianNH macrumors member

    Joined:
    Apr 20, 2015
    #4
    I had to completely reset and re-pair my watch and then it worked.
     

Share This Page