Unable to log in; locked out (Help!)

Discussion in 'MacBook Pro' started by spinergy, May 21, 2017.

  1. spinergy macrumors member

    Joined:
    Oct 16, 2016
    #1
    I can't log into my MacBookPro. I have two SSD's in my MBP. On disk0 I installed OS X 10.11 and all my applications. I then rerouted the home folder to disk1, where all the documents and media is saved on. I turned on FileVault for disk0; rebootet. Then I turned on FileVault for disk1 as well and am now unable to log in to my computer.

    First a white-ish login screen appears with my user and the guest user. I'm prompted to log in with my password, which I do. The loading bar indicates that the system files are loading, but then a second grey-ish login screen appears and I'm prompted to type in my password again. After entering my password there's a pop up message stating "You are unable to log in to the user account "spinergy" at this time. Logging in to the account failed because an error occurred."

    What I've tried so far:
    I booted up in recovery-mode, unlocked the drives in terminal using the coreStorage unlockVolume command and tried to disable FileVault using sudo fdesetup disable. terminal responds with command not found or something similar.

    I can not disable the encryption in Disk Utility. Also, the status under encryption seems to be "Pending" for disk1.

    Is there another way to disable FileVault or stop the encryption process of disk1 without having to erase the whole drive? How can I log in to my account? I'm thankful for any help.
     
  2. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #2
    Have you tried the

    fdesetup authrestart

    Command??
     
  3. spinergy thread starter macrumors member

    Joined:
    Oct 16, 2016
    #3
    No, not yet. I can't even access the recovery screen anymore. All I get is internet-recovery. I'm downloading OS X Lion currently...
     
  4. Gav2k macrumors G3

    Gav2k

    Joined:
    Jul 24, 2009
    #4
    You should be able to access console through the recovery screen
     
  5. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #5
    Forget about FileVault for a moment. Even though FileVault may prevent this from working ... I'd first try to get your data back off that other drive, by trying the solution in this thread:

    https://discussions.apple.com/thread/6084975?tstart=0

    Don't forget, you will probably still have to unlock the drives from CLI before you can mount /.

    FWIW, I'd just do a DIY fusion drive config. You can mitigate risk of data loss due to drive failure by making sure you have Time Machine enabled.
     
  6. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #6
    This is where you went wrong. The OS expects to see a home folder at boot. Since you put the home folder on a second encrypted drive, it is not seen at boot, so the OS won't run.

    Can you command-r boot to recovery? If you can, boot to recovery then use Terminal and the commands described at this site to unencrypt both drive and unwind this.
     
  7. spinergy thread starter macrumors member

    Joined:
    Oct 16, 2016
    #7
    Thank you guys for replying. Because I'm currently writing my bachelor thesis I didn't had too much patience to wait for an actual solution. After downloading and installing OS X Lion I was able to unlock and decrypt disk1. I then formatted disk0 and did a clean install of OS X 10.11. It did not take too much time to set up everything as it was, because I guess licenses and program specific preferences are saved in the user folder. And since those were on disk1, I just had to reinstall all my applications from my Time Machine backup.

    I'm off now purchasing a license for CCC and stop fiddling with settings I don't fully understand. Thank you for your help. I appreciate it!
     

Share This Page