Unable to modify partitions on primary SSD?

Discussion in 'OS X Mavericks (10.9)' started by ideal.dreams, Jul 25, 2014.

  1. ideal.dreams macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #1
    I added a partition to my internal and primary SSD to install Yosemite on. I'm not planning on keeping it there forever and just wanted it there to try some things out. When I try to delete the partition through Disk Utility, I don't have the option to modify any partitions. I can't add, remove, or resize any partitions currently available.

    Would I have to go through the recovery to do this? Really don't want to be missing out on 100GB of already limited SSD space.
     
  2. yjchua95 macrumors 604

    Joined:
    Apr 23, 2011
    Location:
    GVA, KUL, MEL (current), ZQN
    #2
    There's a reason why Yosemite isn't supposed to be installed on primary Macs.

    I ran into the same problem since DP1.
     
  3. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #3
    Just follow this to delete it.

    Installing Yosemite on a second partition for some reason turns it into a core storage volume that can't be deleted in DU.
     
  4. ideal.dreams thread starter macrumors 68020

    ideal.dreams

    Joined:
    Jul 19, 2010
    Location:
    OH
    #4
    I've actually solved the issue after playing around with Disk Utility for a bit.

    Simply format the partition with Disk Utility and then it will allow you to delete the partition. Then the primary partition can be resized back to the full size.
     
  5. chrisrand macrumors member

    Joined:
    Aug 17, 2013
    #5
    Easy fix

    I know this is an old article, but this recently happened to me and the easiest way to get rid of the Yosemite partition is to:

    1) Boot your other OS, mine was Mavericks
    2) Open Disk Utility
    3) Select the Yosemite partition
    4) Select the erase tab, erase it
    5) Select the main drive and go to the partition tab, where you can then delete the Yosemite partition and resize it back to the original size.

    Hope that helps!
     

Share This Page