unable to mount external hard drive

Discussion in 'Mac Basics and Help' started by grrl, May 27, 2007.

  1. grrl macrumors newbie

    Joined:
    May 27, 2007
    #1
    HELP!

    my WD 250gig hard drive was accidentally unplugged while I was uploading pictures onto it. Now i'm unable to mount it.

    I have a Macbook Pro 2.16 GHz Intel Core Duo
    1GB 667 MHz RAM

    I ran disk utility on startup, and it is detected, but I am unable to repair it.

    I also ran Data Rescue II, and just continues to try to detect my external, and when I unplug the USB it detects it. It's whenever I unplug the USB, that it detects it. Could it be the USB cord? I tried to replace it with one from my printer, but nothing changed and it still doesn't work. Can someone please give me any troubleshooting on what to do next? I appreciate anything! Thanks!
     
  2. FJ218700 macrumors 68000

    FJ218700

    Joined:
    Mar 8, 2007
    Location:
    Blue Dot, Red State
    #2
    try shutting down both the drive and computer. Unplug and re-plug in the power and USB on the drive, let it spin for a minute, then turn on the computer. If it still does not mount, will it mount when the same is tried via firewire (provided that is an option?)

    How old is the external drive. I've had several 200 GB WD's and have found that the boards on them generally only last a few years if they are constantly on.

    Good Luck.
     
  3. grrl thread starter macrumors newbie

    Joined:
    May 27, 2007
    #3
    the hard drive is a couple years old. i used to keep it on constantly :(
    im going to have to go out and buy a firewire cable just to try it out...
     

Share This Page