Unable to open Iphoto Library

Discussion in 'iMac' started by VPH, Aug 2, 2012.

  1. VPH macrumors newbie

    Joined:
    Aug 2, 2012
    #1
    When I try to open the iPhoto Library on one of my external drives I get this message:

    " Caution, The Iphoto Library is on a locked volume. Reopen iPhoto when you have read/write access, or reopen iPhoto with the Option Key held down to choose another library".

    How do I unlock the volume?

    I am running Lion and iPhoto 11. I tried all the usual things. Like unlocking the lock in Get Info and changing user from read to read & write, checking the share at the bottom, etc. The problem is everything at the bottom of the Get Information panel is grayed out. Can't change anything but can tick and untick the check at the bottom.

    By the way I have another I photo library on another external drive and I can open that fine but choosing the options key when opening iPhoto and selecting that iPhoto library.

    Any suggestions would be appreciated.

    Thank you
    VPH
     
  2. robgendreau macrumors 68030

    Joined:
    Jul 13, 2008
  3. VPH thread starter macrumors newbie

    Joined:
    Aug 2, 2012
    #3
    Get info on the volume. Can not change anything from read to read & write from the drop down menu. When I click the up or down arrows on the drop down menu nothing shows up. Also, I dont't know how to run the terminal commands. I am new to the mac osx.
     
  4. BenniG macrumors member

    Joined:
    Jun 18, 2012
    #4
    Try following:
    Make a copy of the library/Mediathek
    Open the finder - go to pictures pictures and you will find an iphoto library or something like that, copy this to anywhere on your harddrive or an external harddrive. ( sorry I work with the german labeling of OSX)
    After that follow this
    http://support.apple.com/kb/HT2638

    Depending on your number of pictures this can last the whole night long.

    Good luck !
     
  5. Ice-Cube macrumors 6502a

    Ice-Cube

    Joined:
    Jul 27, 2006
    Location:
    Somewhere over the rainbow
    #5
    Is it because your drive is formatted with NTFS or something?
     
  6. VPH thread starter macrumors newbie

    Joined:
    Aug 2, 2012
    #6
    I checked the format buy openeing the "get info" and it's formated osx extended. Is this the correct way of checking the format of the drive or is there another way of verifying it's not formated for Windows. This external drive worked fine until I upgraded to iPhoto 11.
     
  7. iconboyips macrumors member

    Joined:
    Jan 30, 2008
    #7
    This worked for me, might not be applicable to you.....

    Hi, I don't know if this is the same problem you had but this was mine, and what I did solved it.

    I had an old version of iPhoto. (9.X.X or something). I upgraded to Mountain Lion. iPhoto still worked fine.
    I downloaded the most recent iPhot 11 from the Mac app store on 7 August, installed it. Tried to open iPhoto, got the message:

    iPhoto needs to upgrade you library.

    I clicked upgrade

    I got a message saying it was unable to open library and only option was to quit.

    I tried many support forums suggestions but what did it for me was this:

    I wne to my pictures folder where the iPhoto library was stored.

    I did 'get info' on the picture folder (or Apple i)

    The permissions said my user account had permissions to Read and Write to that folder. So I thought it was okay.

    BUT

    I then unlocked the litte padlock on the get info window

    where it said my username and "Read and Write" I clicked this line once (so it became blue).

    Went to the little settings cog at the bottom of the get info window and selected "Apply to enclosed items"

    Wait for it to do it's stuff.

    Then reopened iPhoto. It told me i needed to upgrade the library, so again I clicked okay.

    Hey presto it worked and started upgrading my library. it took a while (about 10 minutes for a 34Gb library). But it worked and everything it there as it should be.
     
  8. VPH thread starter macrumors newbie

    Joined:
    Aug 2, 2012
    #8
    Yes, this solved my problem. Thank you very much for the detailed instructions.
     
  9. Silvina3a macrumors newbie

    Joined:
    Aug 16, 2012
    Location:
    London
    #9
    Lost Photos in iPhoto

    Hi all. I'm new on this so please be gentle. I need your help. I have saved my photos into iPhoto for the last 2 years.

    About 6 months ago I bought an external hard drive and started using time Machine. In the past, I saved all the pictures manually into a new folder in my MAC.

    However last night, my photos were gone. At 10pm I was looking at the pictures. I shut down the computer when finish. Later on, I need something from my iPhotos. I open iphotos again and there were no pictures.

    I tried to look at the pictures in the back up I have in Time Machine. All the back ups are there but the pictures are gone. Pictures are empty.

    Went to Apple Store today. Genius representative at Apple store in London did not know what to do. He saw the Back ups and my MAC and nothing (only the photos I saved manually) He said smgt might become corrupted and the picts are there but become invisible. I have time machine back ups too but nothing in there. The only picts saved are the one saved manually previously into one of the folders. The pictures saved in time machine cannot be seeing.

    He recommended a data recover which is very expensive! (£+600). He said that I should not reinstalled any program because i might overwrite and delete the pictures. Any other solutions/suggestions?

    What is time machine for if the previous back up don't have the pictures! :(

    Please help. I had more than 5000 pictures gone, among them the 50 year anniversary photos of my parents. I would hate to loose them. Many thanks!!! :)
     
  10. Studeo macrumors newbie

    Joined:
    Dec 6, 2012
    Location:
    Australia
    #10
    Another solution . . .

    I was locked out of all the iPhoto libraries on on 2TB Seagate external drive. The "Get info" menu revealed "Read Access" only. The other external drive was "Read & Write" as well as the iPhoto libraries on the iMac.

    The difference was that the one I could not access my iPhoto libraries on was connected to or via my keyboard. I changed it to the USB connectors on the iMac and it worked.

    Simple fix for me . . . I hope this may help others.
     
  11. ohad macrumors newbie

    Joined:
    Apr 13, 2013
    #11
    Another way to "solve" the problem

    I could not unlock the locked volume in the way described here. But after turning the external hard drive off and turning it on again it was no longer locked
     
  12. antistandard macrumors newbie

    Joined:
    May 5, 2013
    #12
    fixed

    So, I had my external drive plugged in via USB to a 4 usb hub.
    I disconnected it from the hub and plugged it into the mac directly and the library had to rebuild but it worked.
    I had upgraded to the newest version of iPhoto so that is why i had this problem i guess.
     

Share This Page