Unable to print after moving to El Capitan

Discussion in 'OS X El Capitan (10.11)' started by cparent79, Aug 11, 2015.

  1. cparent79 macrumors newbie

    Joined:
    Aug 11, 2015
    #1
    Hey everyone, first post here so don't sling mud yet. I updated to El Capitan as soon as the beta was available and my Dell c1765nfw printer no longer works. I've tried removing/reinstalling printer drivers from Dell with no luck.

    The Print Queue displays an error:

    Stopped - ntdcmsmac open fail:dlopen(/usr/lib/dlthm1zcl.dylib... ...

    In the console I see this error message from cupsd below. To me it looks like a permissions issue, but /private/tmp is fully writable so I don't know what the issue is.


    dlthm1z(26374) deny file-write-create /private/tmp/tmp-25KeEn

    Process: dlthm1z [26374]
    Path: /usr/libexec/cups/filter/dlthm1z
    Load Address: 0x1000
    Identifier: dlthm1z
    Version: ??? (???)
    Code Type: i386 (Native)
    Parent Process: cupsd [26341]

    Date/Time: 2015-08-11 13:10:12.936 -0600
    OS Version: Mac OS X 10.11 (15A243d)
    Report Version: 8

    Thread 0:
    0 libsystem_kernel.dylib 0x9288834a __open_nocancel + 10
    1 libsystem_c.dylib 0x9bb7161f mkstemp + 32
    2 dlthm1z 0x000080ce main + 126
    3 dlthm1z 0x00001ea9 _start + 208
    4 dlthm1z 0x00001dd8 start + 40

    Binary Images:
    0x1000 - 0x12ff7 dlthm1z <7bac08c0-6c2c-cdef-af7a-e617ad08595c> /usr/libexec/cups/filter/dlthm1z
    0x9286e000 - 0x9288efff libsystem_kernel.dylib (3247.1.78) <036a0791-59d9-31cd-9ad0-c1d5b67fb8e3> /usr/lib/system/libsystem_kernel.dylib
    0x9bb30000 - 0x9bbc5ff3 libsystem_c.dylib (1081) <c75f7fb4-381f-3876-8fc3-57353ead5fea> /usr/lib/system/libsystem_c.dylib
     
  2. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #2
    Perhaps you need to disable sip before using your printer. Some folders in /usr/ directory has been locked due to sip.
     
  3. applebutter macrumors newbie

    Joined:
    Oct 30, 2014
    #3
    I have the same printer, same problem, I need to use it so I went back to Yosemite.

    It's not worth a new printer for just an o.s. especially a beta os

    BTW what is sip?
     
  4. lagwagon Suspended

    lagwagon

    Joined:
    Oct 12, 2014
    Location:
    Calgary, Alberta, Canada
    #4
    System Integrity Protection

    Obvious to tell by the name, it protects the system files.
     
  5. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #5
  6. cparent79 thread starter macrumors newbie

    Joined:
    Aug 11, 2015
    #6
    Thanks Shiraski! So disabling SIP definitely "fixed" my printer problem - c1765 installer completes without issue and I can print. Joy. Hopefully Dell will issue a driver compatible with SIP in the near future...

    I had previously scoured the dell support site for any info on this issue and came up empty, which is how I ended up on this forum.

    Thanks
     
  7. Shirasaki macrumors 603

    Shirasaki

    Joined:
    May 16, 2015
    #7
    Congratulations!

    Glad to see this issue has been removed.

    And it seems that currently Apple just implements SIP to prevent modifying system folder, not preventing existing apps from reading data in system folder. However, Apple implies policy may change in the future.

    I don't know if Apple will only allow programs reading unprotected areas in the future.
     
  8. kh26 macrumors newbie

    Joined:
    May 22, 2015
    Location:
    Lincoln, UK
    #8
    For me just disabling SIP did not solve the problem, as the files the printer is expecting to be in /usr/lib are not there. So I disabled SIP, copied the files back to the /usr/lib folder that had been deleted by El Capitan and then re-anabled SIP and it worked fine. Possibly safer than disabling SIP all together.
     
  9. VespaRick macrumors newbie

    VespaRick

    Joined:
    Aug 23, 2015
    #9
  10. kryten42 macrumors 6502

    kryten42

    Joined:
    Sep 17, 2015
    Location:
    In a little world of my own
    #10
    So I had this issue with my Dell c1760nw as it would not print (could not find it). So I used the Dell driver removal tool and then reinstalled the latest drivers from the download package with it setup over IP using the port 9100 option. This is driver version 1.5 for the 1760.
     
  11. SASmith98 macrumors newbie

    SASmith98

    Joined:
    Oct 6, 2015
    #11
  12. happy_golucky_chap macrumors newbie

    Joined:
    Oct 7, 2015
    #12
    Hi There. I have exactly the same problem - same printer. All sorts of issues with Office 2011 not working too.

    anyone else have issues?


     
  13. happy_golucky_chap macrumors newbie

    Joined:
    Oct 7, 2015
    #13
  14. SASmith98 macrumors newbie

    SASmith98

    Joined:
    Oct 6, 2015
    #14
    It's a SIP issue.
    I followed Uwe Honekamp's (http://blog.honekamp.net/blog/2015/09/07/el-cap-and-my-printer/) instructions. Worked perfectly.

    • Download the latest printer driver.
    • Reboot into OS X’s recovery mode.
    • Open Terminal and deactivate SIP by typing csrutil disable. The purpose of this is to let the printer driver’s installer properly do its job.
    • Reboot.
    • Run the printer driver’s installer.
    • Try out printing. Yes!
    • Reboot into recovery mode.
    • Open Terminal and re-activate SIP by typing csrutil enable.
    • Reboot.
    • Try out printing. Still: yes!
     
  15. flowrider macrumors 601

    flowrider

    Joined:
    Nov 23, 2012
    #15
    Again, IMHO, It's not an Apple issue. Apple periodically updates Printer Drivers for a myriad of printer manufacturer's, Dell is NOT one of them. So, in essence the Mac OS does not formally support Dell Printers. Knowing this it is incumbent upon the printer manufacturer, to furnish updated printer drivers with changing OS's if they want to play in the sandbox with Apple machines.

    As far as MS Office 2011 is concerned, it's working quite well for me, and most other members of the forum. Office 2016 is another matter, and MS has acknowledged the problem and is working on a fix.

    Lou
     
  16. happy_golucky_chap macrumors newbie

    Joined:
    Oct 7, 2015
    #16
    Microsoft pushed out an update last night for Office 2011 which has fixed the sync problem that caused the the application to hang. Find it here:

    https://support.microsoft.com/en-us/kb/3098229



     
  17. happy_golucky_chap macrumors newbie

    Joined:
    Oct 7, 2015
    #17
    Worked - thanks for this!
     
  18. Macker15 macrumors newbie

    Macker15

    Joined:
    Oct 8, 2015
    #18
    Thank you so much, this worked for me.
     
  19. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #19
    My HP Photosmart would print just fine but it wouldn't scan.

    HP updated their drivers to work properly however I'd like to mention they don't put much effort into it. Firstly it was asking for an additional letter on the end of the model number mine doesn't have (ends with B1111 but its asking if its B111A B111B or B111G) so I just guessed. And the installer even though it was updated 10-1-15 and auto detected my OS as 10.11 referred to itself as Installer for Mavericks.

    Needless to say they have a convoluted method of finding their lackluster software and their drivers don't inspire confidence. Oh well, it appears to be working ok.

    Point is if you have an HP All-in-one that doesn't scan all you'll need to do is download their latest drivers and reinstall them.
     
  20. whitsdad macrumors newbie

    whitsdad

    Joined:
    Oct 31, 2015
    #20
    Tried this a few minutes and, unfortunately, it didn't work for me. After disabling csrutil, the reboot was unsuccessful and the machine got into a "rebooting do loop". I had to reboot back into recovery mode and reenable the csrutil. Rebooting was then successful in standard mode. Oh well, I guess I'll have to wait for Dell printer driver updates.
     
  21. shorshe macrumors newbie

    Joined:
    Dec 5, 2015
    #22

Share This Page