Unable to print from MacBook to Networked Printers

Discussion in 'macOS' started by Bedivere, Aug 20, 2007.

  1. Bedivere macrumors newbie

    Joined:
    Aug 20, 2007
    Location:
    Midwest USA
    #1
    I'm a newbie to Macs (recent escapee from M$ and years of PC experience). I recently got a MacBook with OSX 10.4.10 and have it working nicely on my home network with other Windows machines and a NAS. However, despite the fact that the Mac and Windows machines are able to share files/folders, the Mac can't see any of the three printers. I've posted this issue on Apple Support forums but didn't get any resolution so would appreciate any help you all can provide.

    Here's my network: PC1 with WinXP and an HP932C printer, NAS drive with HP6110 printer and DYMO label printer, PC2 with Win2K.

    When I try to add one of the printers to the MacBook, the process results in "Unable to connect to the server with the provided user name and password; error:256". All the machines are in the same workgroup and as I said, file sharing works just fine. The NAS drive (Simpletech) does not require a login or password to use the printers. Neither does the PC hosting the HP932C.

    To make matters goofier, I've installed Parallels and WinXP on the Mac and was able to install a printer in Windows and print to it successfully! OSX remains unable to see/connect to any of the printers. If I direct connect the HP6110 to the Mac, printing is a piece of cake.

    I tried setting up the HP6110 as an IP printer and it sets up as though it's ready to go. I tried sending a text test file to this printer and that went OK as well; except it didn't print. After a short wait, the following error message appears:
    "Network host '\\Sherman\OfficeJet-6100-Series' is busy, down, or unreachable; will retry in 30 seconds...."

    I also tried setting up the printer using the IP address as "192.168.0.5" and the same printer name as above. The printer was created, but gave me the same error message when attempting a test print. I also tried setup using two drivers; the OJ6110 driver and the driver for an HPDJ990c, which is what HP told me to use when I first set up the NAS drive as printer server. The OJ6110 is a multifunction printer, and some of the features don't work over a network (such scanning).

    I am very frustrated :confused: trying to get network printing to work. If anyone can provide me with an answer, I'd be grateful. I've tried to include enough detail to figure this out, but if you need more info, just ask.
     
  2. MisterMe macrumors G4

    MisterMe

    Joined:
    Jul 17, 2002
    Location:
    USA
    #2
    With rare exception, you must use CUPS drivers to print to a networked printer. This question has been asked and answered on this forum every two or three hours. Search this forum for CUPS and Gutenprint.
     

Share This Page