Unable to print...

Discussion in 'Mac Basics and Help' started by chelseasian, Jan 3, 2008.

  1. chelseasian macrumors regular

    chelseasian

    Joined:
    Oct 20, 2004
    Location:
    New York, NY (Chelsea)
    #1
    Hi!

    I have an Epson Stylus Photo R340 hooked up via Airport Base. I am running OS 10.5.1 (Leopard) and for the longest time since I've upgraded I have not been able to print. It is very frustrating. I am able to detect the printer via Bonjour network but every time I send a job to print, in the print window it will always say connecting but it never connects.

    Does anyone know of a workaround or should I just trash and buy a Leopard compatible printer?

    [​IMG]

    I appreciate any feedback.

    Thank you.
    :confused:
     
  2. seniorstinky macrumors regular

    Joined:
    Feb 22, 2007
    Location:
    Phoenix, AZ
    #2
    Leopard has drivers built in for this printer so you shouldn't need a new one.

    Have you tried to install the printer again?
     
  3. tammy418 macrumors member

    Joined:
    Nov 15, 2006
    Location:
    Gainesville/Miami
    #3
    I was having the same problem with my HP printer. I ended up uninstalling the drivers and software that came with the printer and installed the ones that are included in the Leopard DVD and it works now. So I a guessing that is what you need to do.
     

Share This Page