General "Unable to purchase" Cydia, 7.1b2

Discussion in 'Jailbreaks and iOS Hacks' started by Paradoxally, Jan 3, 2014.

  1. Paradoxally macrumors 65816

    Joined:
    Feb 4, 2011
    #1
    I am unable to purchase any package in Cydia that has not been previously purchased using my iPhone 5 on 7.1b2. Cydia states "unable to purchase", claiming my ios device is not supported.

    I've already removed the expiry using the thread here on macrumors, so I plan on staying on this firmware if 7.1b3 includes patches by Apple to close the JB. I don't want to downgrade to 7.0.4 as 7.1b2 has been very stable.

    I did try to spoof my version by changing the build to ios 7.0.4's and version to 7.0.4 instead of 7.1 on that .plist file. Settings read 7.0.4, but Cydia still shows 7.1 even after a reboot.

    I can download free packages, just not purchase anything. I want to buy some themes and tweaks but unfortunately this won't let me and I don't want to resort to piracy-filled repos. Has anyone been able to spoof Cydia into thinking your 7.1b2 device is running 7.0.4?
     
  2. gotluck macrumors 603

    gotluck

    Joined:
    Dec 8, 2011
    Location:
    East Central Florida
    #2
    I've had the same problem you are referring to. On my first jb of 7.1b2 I had left the version at 7.1 for a good bit, then changed it to 7.0.4 and was able to purchase. So in that respect my experience was different than yours. However cydia continued to display 7.1.

    I've since restored 7.1b2 again and this time changed the version number to 7.0.4 at first opportunity , at the same time as the build number change and the beta line removal. Now my cydia reads 7.0.4 and I continue to have the ability to purchase.

    FWIW :)

    I have a hunch a hard reset may make cydia recognize the change. I can't remember if I tried that.
     
  3. Paradoxally thread starter macrumors 65816

    Joined:
    Feb 4, 2011
    #3
    Perfect, your second solution worked for me!

    For anyone wondering how-to: backup your data with iTunes/iCloud, restore to iOS 7.1b2 (I did DFU restore, as I always generally do), then restore your settings/apps back.

    Jailbreak, open Cydia, install the required packages and respring (it prompts you to).

    Install iFile, go to the folder where the .plist is located (/System/Library/CoreServices/SystemVersion.plist), and change the following at the same time:

    - ProductBuildVersion to 11B554a
    - ProductVersion to 7.0.4
    - delete the beta key

    Tap 'done', close iFile and do a hard reboot (turn it off and on again manually). Open up Cydia, it should show 7.0.4 at the bottom. Now you can purchase packages on 7.1b2, which offers better performance than 7.0.4. :)

    Thanks gotluck!
     
  4. gotluck, Jan 3, 2014
    Last edited: Jan 3, 2014

    gotluck macrumors 603

    gotluck

    Joined:
    Dec 8, 2011
    Location:
    East Central Florida
    #4
    Awesome write up :)

    Now we cross our fingers and hope this actually works post expiration :p
     
  5. wildonrio macrumors 6502

    Joined:
    Aug 15, 2008
    #5
    I tried this and I am now able to install apps that I previously could not on 7.1, but it still says I'm on 7.1 at the bottom of Cydia. Apps also don't show up in my springboard until after a full reboot.
     
  6. thadoggfather, Jan 6, 2014
    Last edited: Jan 6, 2014

    thadoggfather Suspended

    thadoggfather

    Joined:
    Oct 1, 2007
    #6
    What device are you on? Same thing with me on rMini wifi version.

    But I'm able to purchase tweaks like Infiniboard if I want, doesnt prompt me stating invalid version despite Cydia still reading 7.1 after 7.0.4 plist changes.

    just restored and applied plist edits and rebooted and such, shows 7.0.4 on rMini now. Both devices now show 7.0.4 :D
     
  7. SixSlinger macrumors regular

    SixSlinger

    Joined:
    Jun 28, 2007
    Location:
    Atlanta
    #7
    Thanks for this. Works perfectly for me on 5s and mini Retina 7.1b3
     
  8. gotluck macrumors 603

    gotluck

    Joined:
    Dec 8, 2011
    Location:
    East Central Florida
    #8
    You jailbroke beta3?!
     
  9. dan542 macrumors newbie

    Joined:
    Jun 18, 2013
    Location:
    Prague, Czech Republic
    #9
    Me too... Just open the evasi0n7 binary in Hex Friend (or any other hex editor) and replace the 7.1b2 build number (11D5115d) with the 7.1b3 one (11D5127c).
     
  10. Twla macrumors newbie

    Joined:
    Jan 29, 2014
    #10
    [/COLOR]
    I have the same Problem, but I have installed IOS 7.0.4
    Can someone help me?

    Thx in advance:(:confused:
     
  11. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #11
    Are you sure the tweak is updated for iOS 7?
     

Share This Page