Unable to recover password with install disc

Discussion in 'macOS' started by Thomas Blake, Aug 13, 2007.

  1. Thomas Blake macrumors newbie

    Joined:
    Aug 13, 2007
    #1
    My brother forgot the password to his iBook's only administrator account. I booted the computer using the OS X Tiger install disc, and then used the Password Reset Utility to set a new password for his user account. I then rebooted the computer.

    The computer asked me to log in. This is odd, because he has the computer set to automatically log in. Anyway, I input his username and the new password. The computer rejected the new password, which I am absolutely sure was spelled and typed correctly. I tried entering the password using both his short name and long name. Neither worked.

    I rebooted the computer, and once again booted to the Mac OS X install disc. I attempted to use the password reset utility again, however this time the password reset utility claims that Macintosh HD has no user accounts.

    How should I proceed from here, making sure not to lose any data?
     
  2. tennismanclay macrumors regular

    tennismanclay

    Joined:
    May 11, 2007
    Location:
    US-Texas
    #2
    ok, so i dunno if its against the rules of the forum to post this but im going to.


    IF putting in the install disks dont work, restart the computer and hold apple s

    you will then be sent into single user mode, when you become able to type, type in this exactly


    mount -uw / (then hit enter)
    sh /etc/rc (then hit enter, it could take a while)
    passwd *the admins shortname* (then hit enter)
    type in a new password, it wont show up but your typing it,
    confirm it
    then type reboot and when u get to the login screen enter the new password and hopefully it will work

    hope this works,

    Clay
     
  3. MacMarket macrumors newbie

    Joined:
    Jan 6, 2009
    #4
    Clay,

    I have the same problem as Thomas Blake. something has gone wrong with my G5 running OS X 10.4.11 and now instead of automatically booting up on restart I am being prompted to log in, and my password is being rejected. I tried booting up from the install disk and using the reset password utility, but this had no effect. I even tried to reinstall the original OS X 10.4 from the installation disk, but this process aborted with an error message after some minutes. So I tried going into single user mode, which I have never used before. I am not familiar with Unix commands. I found some instructions similar to those you have given on the Internet but they did not mention the need to use the 'short name' so I entered 'Richard Bancroft' which is the user name appearing when the log in window appears. This had no effect. I didn't realise I had a short name. Where is this to be found? I have a Mac Powerbook which has the same system exactly and which is not experiencing the log in problems of my G5, so I can check on that what my 'short name' is (probably 'Richard').

    Many thanks,

    Richard Bancroft


     

Share This Page