Unable to remove/delete icons from dock

Discussion in 'macOS' started by Excelox, Feb 23, 2010.

  1. Excelox macrumors newbie

    Joined:
    Feb 23, 2010
    #1
    Need help! I am unable to remove / delete icons from the dock - any idea why? Once apon a time I could just drag and drop onto the desktop in a cloud of smoke, or drag to Trash. Not any more.
    I have tried the following; repairing disk permissions; 'killall dock' command using terminal; checked parental control is OFF; deleting the com.apple.dock.db
    com.apple.dock.plist
    files from Macintosh HD,Users,Library,Preferences.

    This is driving me crazy , any help would be appreciated :)
     
  2. r0k macrumors 68040

    r0k

    Joined:
    Mar 3, 2008
    Location:
    Detroit
    #2
    Some icons won't go "poof". Most others will.

    I don't think you can drag certain items off the dock.

    I got rid of garage band and itunes right away. Others I dragged to the dock from applications. Have you tried option-clicking (or right-clicking) on the blank area in the dock just left of documents and taking a look at dock preferences?

    More here...
     
  3. Schtumple macrumors 601

    Schtumple

    Joined:
    Jun 13, 2007
    Location:
    benkadams.com
    #3
    If you have the application Onyx, and have recently been roaming about in the settings, there was a tickbox that would lock the dock items, that it?
     
  4. Norskman macrumors member

    Norskman

    Joined:
    Feb 23, 2010
    #4
    That is exactly what I did. Being a Windows convert I'm definitely a Mac OS newbie and this drove me batty until this site provided the answer. After un-checking this option I was able to clean up the dock. Some icons it won't let you remove though.
     
  5. Pin-Up Girl macrumors newbie

    Joined:
    May 24, 2011
    #5
    I'm having the same problem. It won't let me remove address book, preview, or TextEdit. :confused: It's getting really annoying! It even pretends it's going to let me delete it and shows the little poof thing and when I drag it over the trash can it says "Remove from Dock" but it just goes right back to the dock.
     
  6. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #6
    On which Mac OS X version does that happen?
    Are you sure, that Address Book or Text Edit are not running?

    See the blue indicator light below the Text Edit icon, to show you what is open and what is not?

    Text Edit not open:
    [​IMG]

    Text Edit open:
    [​IMG]
     

Share This Page