Unable to remove login items (Revert after reboot)

Discussion in 'macOS' started by OngL, Apr 24, 2011.

  1. OngL macrumors member

    Joined:
    Feb 17, 2009
    #1
    I am having issues and permanent encounter in having my removed login items reappearing after reboot.

    Here's the steps I have taken:
    1) Open Setting, Account Preferences, Click under an account, Login item tab
    2) Remove some login items (with or without unlocking the lock, doesn't seems make a different, tried both)
    3) Login items are now fewer
    4) Reboot
    5) voila, the removed login items are still loaded and displayed in login item tab.

    I have also removed loginitem.plist under ~/Library/Preferences. Doesn't seems making a difference. The problem also observed both in MBP and iMac

    How to solve this? Tried to google, no answer.
     
  2. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #2
    My guess is that the software the login item belongs to is reinstalling it. Try checking the software's preferences to see if there is an option for the login item that can be turned off.
     
  3. OngL thread starter macrumors member

    Joined:
    Feb 17, 2009
    #3
    I tried to go to some of the apps, to disable the "helper" from preferences. Such apps are: PhoneView, Interarchy, etc... It still won't stick.

    Hoping to get a solution rather than reformatting everything. I wish I knew where does the OS managed to rebuild the login item list after I deleted the two files *login* in ~/Library/Preferences
     
  4. DewGuy1999 macrumors 68040

    DewGuy1999

    Joined:
    Jan 25, 2009
    #4
    Have you tried repairing permissions with Disk Utility?
     
  5. xyzzy-xyzzy macrumors member

    Joined:
    Sep 19, 2010
    #5
    Can you list (name) the apps or login items that you are talking about? Perhaps some of us might know something about their specific behavior that might explain your problem.
     
  6. apta macrumors newbie

    Joined:
    Mar 6, 2008
    #6
    This worked for me

    I too experienced all you say. Besides removing the files you mention, I threw out every cache file I could find (visible and invisible) and even the Sytems's CCacheServer. Nothing worked.

    Finally I decided to boot up in Safe Boot mode (shift down) hoping it would clean up caches I didn't know about. I first removed the unwanted login items and then Safe Boot'ed. Sure enough it worked!

    I don't know what file or folder was creating the reappearance of the login items. Safe Boot deletes the dynamic loader shared cache at (/var/db/dyld/) but manually forcing the loader (sudo update_dyld_shared_cache -force) to update had no effect.

    By the way, only one of my user accounts had this problem implying that the culprit most likely was inside that user folder. But that's just a guess.
     
  7. greencat365 macrumors newbie

    Joined:
    Jan 23, 2015
    #7
    I had the same problem. For me, the culprit was Dropbox. It keeps making itself a login item even if I remove it from the login items list via System Preferences. For some reason, this reverts the entire login items list.

    You can make Dropbox not a login item via Dropbox's preferences, which solved the problem for me.
     

Share This Page