Unable to remove "This item will be deleted immediately" Trash window

Discussion in 'macOS' started by janush, Dec 8, 2009.

  1. janush macrumors newbie

    Joined:
    Dec 8, 2009
    #1
    Whenever I move a file to Trash or use the delete command a pop message comes up "This item will be deleted immediately. You can’t undo this action" - 'Show warning' is not selected in finder preferences. I have a nine day old 27" gi7 imac where I copied all the settings from my macbook pro via time machine. Both machines were on 10.6.2 and I am the only user - this problem only surfaced today. I ran Repair Disk Permissions with no luck and called Apple….. they said that the only way to get rid of this was to perform a clean install making sure to back-up everything. I said that that was crazy and would involve me in having to invest in a new HD as I've already filled the imac with 500gb of stuff that has now been wiped over and I don't have a spare 500 gigs kicking around. I told them that I'm pretty sure a simple Terminal command would do the trick but they told me that they don't train their "help" to use it and that it was there for developers. I said that as it was their software which they installed then they should at least have people on the end of the phone that could help. After causing a fuss and wanting to make complaints I was passed to a senior guy who tracked down this exact problem on an Apple support forum. We went through the terminal commands with no luck - he then suggested I post on this site….. so, here I am. Any suggestions will be kindly appreciated.




    Here's the breakdown on what I did based on the suggestions from the Apple Support forum:

    "Repair disk permissions
    Repairing permissions for “Macintosh HD”
    ACL found but not expected on "private/etc/apache2/httpd.conf".
    Repaired "private/etc/apache2/httpd.conf".
    ACL found but not expected on "private/etc/apache2/users".
    Repaired "private/etc/apache2/users".
    ACL found but not expected on "private/etc/postfix/main.cf".
    Repaired "private/etc/postfix/main.cf".
    ACL found but not expected on "private/etc/postfix/main.cf.default".
    Repaired "private/etc/postfix/main.cf.default".
    Permissions differ on "usr/share/derby", should be drwxr-xr-x , they are lrwxr-xr-x .
    Repaired "usr/share/derby".
    ACL found but not expected on "Library/Preferences/Audio".
    Repaired "Library/Preferences/Audio".
    ACL found but not expected on "Library/Preferences/com.apple.alf.plist".
    Repaired "Library/Preferences/com.apple.alf.plist".
    Warning: SUID file "System/Library/CoreServices/RemoteManagement/ARDAgent.app/Contents/MacOS/ARDAgent" has been modified and will not be repaired.
    ACL found but not expected on "System/Library/Keychains/X509Anchors".
    Repaired "System/Library/Keychains/X509Anchors".
    ACL found but not expected on "private/etc/hostconfig".
    Repaired "private/etc/hostconfig".
    ACL found but not expected on "private/var/db/launchd.db/com.apple.launchd".
    Repaired "private/var/db/launchd.db/com.apple.launchd".
    ACL found but not expected on "private/var/yp/binding".
    Repaired "private/var/yp/binding".

    Permissions repair complete



    Next I posted this in terminal
    ls -ale@ ~/.Trash

    got this reply
    ls: .Trash: Permission denied


    Next I posted this based on a second suggestion
    sudo ls -ale@ ~/.Trash
    Password:
    total 0
    drwx------ 3 root MY NAME 102 8 Dec 02:54 .
    drwxr-xr-x+ 32 MY NAME MY NAME 1088 8 Dec 17:29 ..
    0: group:everyone deny delete
    drwx------@ 4 MY NAME MY NAME 136 7 Dec 14:40 Recovered files
    com.apple.quarantine 58


    then tried this
    mkdir ~/.Trash

    got this
    mkdir: /Users/MY NAME/.Trash: File exists
    localhost:~ MY NAME$



    I swapped "MY NAME" for my name.
     
  2. PurrBall macrumors 6502a

    PurrBall

    Joined:
    Oct 25, 2007
    Location:
    Indianapolis
    #2
    I would go to Go > Go to Folder, type ~/.Trash right-click inside the folder, Get Info, expand Sharing & Permissions and give yourself permissions and ownership.
     
  3. janush thread starter macrumors newbie

    Joined:
    Dec 8, 2009
    #3
    thanks for the help - I got this from someone at the Apple forum which fixed it:

    Try the following in Terminal

    > sudo rm -r ~/.Trash

    Enter your password when promted. If you get an error with this
    one then the following one won't work.
    To recreate the directory...

    > mkdir ~/.Trash

    Logout then login again.
     
  4. gbeast macrumors newbie

    Joined:
    Feb 17, 2010
    #4
    Thank you.

    I started having the same problem a few days ago. This was the first post I read and it worked. Janush, thank you for going to all the hassle to figure this out and saving me the trouble.
    :D
     
  5. mab macrumors newbie

    Joined:
    Feb 19, 2010
    #5
    An easier way?

    I just started receiving the same error a few minutes ago. What worked for me was just quitting the Finder and restarting it.
     
  6. ephierisho macrumors newbie

    Joined:
    Oct 29, 2010
    #6
    It worked!

    Thanks a million! I tried researching this on a few forums, and your simple explanation using Terminal to delete then create the Trash folder worked like a charm. No more problems!

    My issue had started when I ran Disk First Aid on my system. Glad to know it's fixed!
     
  7. jimmygster macrumors newbie

    Joined:
    Nov 7, 2010
    #7
    I had the same problem. I did a force quit on the finder, and it's back to normal now.

    Thanks for the tip to quit finder, above.
     
  8. Hal Itosis, Nov 7, 2010
    Last edited: Nov 7, 2010

    Hal Itosis macrumors 6502a

    Hal Itosis

    Joined:
    Feb 20, 2010
    #8
    There are two (three) possible way this situation can arise:
    1. some program deletes your user trash folder, so there's nothing there for items to go into.

    2. some program gives root (or some other user) ownership of your user trash folder (or prevents access somehow).

    3. or, the item you're "moving to the trash" is actually on a networked share... in which case the behavior is perfectly normal.
    For case 1., restarting or logging out/in (or perhaps relaunching Finder) will suffice.

    For case 2., the sudo rm -r ~/.Trash solution will be necessary (or some other command which normalizes ownership/permissions), followed with a Finder relaunch.
     
  9. anti_ macrumors member

    anti_

    Joined:
    Dec 12, 2009
    Location:
    S. California
    #9
    "sudo rm -r ~/.Trash" didn't actually work but relaunching Finder did though. thanks guys. shout-out to mab for the tip.
     
  10. Jeff1919 macrumors newbie

    Joined:
    Jan 12, 2012
    #10
    The easiest way to fix this is to go to Home folder (Shift, command-H). Then, get info (command-I).

    Look at bottom of info, Sharing and Permissions. You (Me) should get set to Read & Write. Mine was set to Read Only. After changing it, it worked perfect. I'm using OS 10.6.8
     
  11. gmanist1000 macrumors 68030

    gmanist1000

    Joined:
    Sep 22, 2009
    #11
    This works for me. 10.7.3
     
  12. tgelb macrumors newbie

    Joined:
    Mar 16, 2012
    #12
    So I looked at the permissions on my computer and I am already read/write, so that's not my issue. However, I don't know where to go to try to do those other things. Can someone direct me by being more specific...like "in finder, to to mac hd, then applications, then blah blah blah" I truly do not know where the "Go" file is or "Terminal".

    Thank you. I would love to get this resolved soon.
    hmm? does this board have a notify me when someone responds box? Can't find that either. oh, I'm lost for sure.

    Ah, found it...Scroll down. :)
     
  13. tgelb macrumors newbie

    Joined:
    Mar 16, 2012
    #13
    I have tried this a few times (finally found terminal) but it says permission denied. But when I look at the permissions, it says that I can read & write, so I am super confused. This computer is really wacking out lately.
     
  14. bert.sunshine macrumors newbie

    Joined:
    Mar 23, 2012
    #14
    Same problem

    I have the same message for some days.

    I cannot see a /.Trash folder on the system
    When i try to remove it says no such directory.
    But I also cannot make one, (permission denied).

    What's next?

    Hope somebody can tell.

    Gr.

    Macbook Pro 10.7.3

    Last login: Fri Mar 23 08:35:38 on console
    Berts-MacBook-Pro:~ Home$ > sudo rm -r ~/.Trash
    -bash: sudo: Permission denied
    Berts-MacBook-Pro:~ Home$ >mkdir ˜/.Trash
    -bash: mkdir: Permission denied
    Berts-MacBook-Pro:~ Home$ ls -lOa ~/.Trash
    ls: /Users/Home/.Trash: No such file or directory
    Berts-MacBook-Pro:~ Home$ chown ~/.Trash
    usage: chown [-fhv] [-R [-H | -L | -P]] owner[:group] file ...
    chown [-fhv] [-R [-H | -L | -P]] :group file ...
    Berts-MacBook-Pro:~ Home$ chgrp staff ~/.Trash
    chgrp: /Users/Home/.Trash: No such file or directory
    Berts-MacBook-Pro:~ Home$ chmod 700 ~/.Trash (which is: rwx——)
    -bash: syntax error near unexpected token `('
    Berts-MacBook-Pro:~ Home$ chown ˜/.Trash
    usage: chown [-fhv] [-R [-H | -L | -P]] owner[:group] file ...
    chown [-fhv] [-R [-H | -L | -P]] :group file ...
    Berts-MacBook-Pro:~ Home$ chgrp staff ˜/.Trash
    chgrp: ˜/.Trash: No such file or directory
    Berts-MacBook-Pro:~ Home$ chmod 700 ˜/.Trash
    chmod: ˜/.Trash: No such file or directory
    Berts-MacBook-Pro:~ Home$
    Berts-MacBook-Pro:~ Home$ 16:50 on console
    Berts-MacBook-Pro:~ Home$ ls -al ~
    total 72
    drwxr-xr-x 19 bert staff 646 Feb 19 21:00 .
    drwxr-xr-x 5 root admin 170 Nov 4 15:12 ..
    -rw------- 1 Home staff 3 Mar 5 2009 .CFUserTextEncoding
    -rw-r--r--@ 1 Home staff 24580 Mar 23 14:18 .DS_Store
    -rw------- 1 Home staff 0 Jan 28 2011 .Xauthority
    drwxr-x--x 4 Home staff 136 Jan 2 13:09 .adobe
    -rw------- 1 Home staff 355 Mar 23 14:59 .bash_history
    drwx------ 3 Home staff 102 Jul 14 2009 .cups
    drwx------ 10 Home staff 340 Mar 1 2010 .filezilla
    drwxr-xr-x 6 Home staff 204 Jan 28 2011 .fontconfig
    drwx------ 15 Home staff 510 Mar 17 22:51 Desktop
    drwx------ 15 Home staff 510 Nov 15 07:51 Documents
    drwx------ 191 Home staff 6494 Mar 23 15:17 Downloads
    drwx------@ 57 Home staff 1938 Mar 19 13:26 Library
    drwx------ 17 Home staff 578 Mar 9 19:46 Movies
    drwx------ 6 Home staff 204 Nov 6 18:00 Music
    drwx------ 19 Home staff 646 Feb 27 06:10 Pictures
    drwxr-xr-x+ 18 Home staff 612 Jan 18 13:45 Public
    drwxr-xr-x 6 Home staff 204 Mar 10 2009 Sites
    Berts-MacBook-Pro:~ Home$ mkdir ~/.Trash
    mkdir: /Users/Home/.Trash: Permission denied
    Berts-MacBook-Pro:~ Home$ sudo rm -r ~/.Trash

    WARNING: Improper use of the sudo command could lead to data loss
    or the deletion of important system files. Please double-check your
    typing when using sudo. Type "man sudo" for more information.

    To proceed, enter your password, or type Ctrl-C to abort.

    Password:
    rm: /Users/Home/.Trash: No such file or directory
    Berts-MacBook-Pro:~ Home$ mkdir ˜/.Trash
    mkdir: ˜: No such file or directory
    Berts-MacBook-Pro:~ Home$ chmod -R -N ~
    chmod: Failed to clear ACL on file ubiquity.socket: Invalid argument
    chmod: /Users/Home/Library/Saved Application State/fi.eye.updater.savedState: Permission denied
    chmod: /Users/Home/Public/.TemporaryItems/folders.501: Permission denied
    Berts-MacBook-Pro:~ Home$
     
  15. David Lipschitz macrumors newbie

    Joined:
    Jun 6, 2012
    Location:
    Milnerton, Cape Town, South Africa
    #15
    Fixing Move to Trash

    Please read everything before doing anything.

    Apple runs on Unix. The wonderful thing about Unix is that fundamentally it hasn't changed in 30 years (since I started using it) and most commands have been around just as long.

    To fix the "Finder Deletes Files Immediately and doesn't move files to Trash" Problem:

    Load Terminal. If you don't know how to do this, then either: (A) Use Spotlight. Type terminal. Select the Terminal program with its little black window icon; OR (B) Run Finder, select Applications, Utilities, Terminal.
    1. pwd <enter> you should be in /Users/<your-username>
    2. ls -la
    3. If .Trash exists: sudo rm -r ~/.Trash
    4. If .Trash doesn't exist: sudo mkdir ~/.Trash
    5. ls -la to check your user name and permissions
    6. sudo chmod 700 .Trash
    7. sudo chown <your-username> .Trash

    If you are asked for your password, enter the same password you use when you log in.

    • pwd = print working directory. "Print" in Unix prints to the console (your screen).
    • "ls" = list. Like "dir" in DOS/Windows.
    • "ls -l"= list everything, but directories starting with . are not displayed.
    • "ls -la" = list everything, including directories starting with .
    • If you have lots of directories and don't want to scroll up, use "ls -la | more". The "|" means "pipe", ie send the output to. The "more" means show one page at a time. After looking at the page, you can press <enter> to look at the next page, or "q" to quit the "more" command.
    • chmod fixes permissions.
    • chown changes your username from root to <your-username>.

    Do not enter the "" above. They are there to show you the commands and their options/parameters.

    You should be good to go.

    PS: Be very careful with rm -r. You can remove your entire drive's data with it. Make sure you are in the right path (directory/folder) and be very careful. The "-r" parameter says "remove everything inside this path, ie to terminate with extreme prejudice, ie just like James Bond." Be very careful.

    PPS: Thank you for all the support I have received at MacRumours over the years. I pray that this message gives a little bit back.
     
  16. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #16
    You should not use sudo if you create a file or folder within ~/, because this means that the current user is no longer the owner of the file or folder.

    This is not necessary. Mac OS X gives the trash can automatically the correct access permissions. If you really want to specify access permissions, you can do this with the mkdir command via the -m parameter.

    Btw, here is an AppleScript, which solves the trash can problem:
    http://forums.macrumors.com/showthread.php?p=13005577#post13005577
     
  17. rachinc macrumors newbie

    Joined:
    Jul 17, 2008
    #17
    "This item will be deleted immediately" warning for EXTERNAL HARD DRIVE ONLY

    Whenever I take a file on my desktop and delete it, it goes into the trash without any warnings (as should it). Then I go to my EXTERNAL HARD DRIVE (G Speed eS) and try to delet a file and I get the warning "This Item will be deleted immediately". I want that warning to go away. So I started googling solutions to make it go away. But all the suggestions seemed specific to your COMPUTER not your EXTERNAL HARD DRIVE. Such as permissions... permissions seem to be "read & write" for my user on both my computer and external hard drive.

    I didn't follow all the steps here (http://www.thexlab.com/faqs/trash.html#Anchor-Files-46919) because again I thought maybe those steps were specific to your computer, not your external hard drive.

    Any tips? hints? ideas on how to solve this?

    Running 10.8.5
    Intel iMac Build 12F45
     
  18. OGDK macrumors member

    Joined:
    Feb 11, 2014
    #18
    It was probably both. I ran into the same problem when I did something stupid with my trash folder once.

    ----------

    I can't replicate your problem, but I have something you can at least give a shot at, which is deleting the external hard drive's trash folder so it can be recreated:

    Make sure there's nothing in the Trash that you need. Open Terminal. Type "cd " (without quotes, space is important), then drag your external hard drive's icon from Finder into the Terminal window. You should get something like "cd /Volumes/HardDriveName". Hit return. Then do "sudo rm -r .Trashes". Then "killall Finder" to relaunch finder.
     
  19. ira22 macrumors newbie

    Joined:
    Jul 14, 2015
    #19
    Hi, I'm getting the "this item will be deleted immediately" message for quite some time now. I first thought my disk might be full, but it is pretty empty. The problem first appeared when I was still on OS X 10.6, in the meantime I moved to Yosemite, but the situation is unchanged.
    I tried basically everything suggested in this forum (and elsewhere). Force quit finder didn't work. In "settings and permissions" everything seems ok, but when I go to terminal and type "ls ~/.trash" I get "permission denied". When I type "sudo rm -ri ~/.Trash" I'm asked to enter my password but am actually unable to do just this.
    Any ideas??
    Thank you!
     
  20. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #20
    "When I type "sudo rm -ri ~/.Trash" I'm asked to enter my password but am actually unable to do just this"

    What do you mean?

    What happens when you type your password?
     
  21. ira22 macrumors newbie

    Joined:
    Jul 14, 2015
    #21
    A strange thing indeed: I just can't enter any characters.
     
  22. Fishrrman macrumors G4

    Joined:
    Feb 20, 2009
    #22
    "A strange thing indeed: I just can't enter any characters."

    Are you taking into consideration the fact that when you enter an administrative password into the Terminal, it does not show you anything as you type?
     
  23. ira22 macrumors newbie

    Joined:
    Jul 14, 2015
    #23
    Thanks Fishrrman! You were right, I was just being stupid. The empty and recreate trash procedure worked! Everything is okay again. I even found out where the problem came from : Some DVD I watched months ago had somehow interfered with the trash account.
     

Share This Page