Unable to repair Time Machine partition

Discussion in 'Mac Basics and Help' started by timsaxman, Sep 13, 2014.

  1. timsaxman macrumors member

    Joined:
    Feb 13, 2013
    #1
    Hi

    I have a 2 TB External drive on which I have a partition for Time Machine (and another for photos etc.). A couple of days ago when I was going to back up my computer it couldn't find the partition. I opened Disk Utility (have tried both in OS X and Recovery mode) and tried to repair it, erase it, erase the drive and start over but nothing has been successful. I have attached a screenshot from Disk utility, but the errors I've seen so far are:

    • "Couldn't unmount disk"

    • "Live file system repair is not supported"

    • "Ownership of the affected disk is required"

    Also, as I'm typing this using my browser in full screen mode, the partition with photos keeps mounting over and over again. I noticed this since it automatically swiped to the desktop and despite me trying to unmount it it won't and it just mounts again (even though it's already mounted).

    If you want more screenshots just tell me what to do and what I should screenshot.
     

    Attached Files:

  2. timsaxman thread starter macrumors member

    Joined:
    Feb 13, 2013
    #2
    Solved it by plugging it in to a computer with Windows and just formated it using Disk management.
     

Share This Page