Unable to restore 2G iPod Touch - Dead?

Discussion in 'iPod touch Hacks' started by kAoTiX, Sep 25, 2009.

  1. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #1
    I have been searching the net for hours, trying various combinations of things. Different firmware etc but I still have the same problem I've had since I started.

    An iPod Touch 2G 16GB someone gave me wont restore no matter what I do.
    When I turn it on it gives me the plug into iTunes image, so I plug it in and iTunes says it's in recovery mode.
    If I tell it to restore, it extracts the firmware and then prepares the iPod for restore. During this it fails and says it can't be restored, Unknown error (1603)

    I've tried on different computers (PCs not MACs) different USB ports.
    I have the latest iTunes and I'm (apparently) trying to restore to 3.1.1
    The only thing I can think is that this iPod clearly hasn't been attached to a computer for a long time so the firmware on it is probably quite old. Could this be causing it to fail the restore?

    Any help would be greatly appreciated.
     
  2. drjataylor macrumors newbie

    Joined:
    Sep 30, 2009
    #2
    iPod Touch software upgrade problem

    I have exactly the same problem.

    I returned my iPod to a local Apple service company, and they have replaced it with another running the 2.2.1 software. I re-synced this new iPod successfully and it was working OK, but when I tried to install 3.1.1 again, it did exactly the same as the previous iPod.

    I am running iTunes 9 on Vista on a PC.

    I have tried all of the advice offered by the Apple web site without success (set up new user account and try again, open ports 80 & 443, try different USB port etc etc)

    If you find a solution, please post it.

    Sorry can't be more constructive
     
  3. kAoTiX thread starter macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #3
    Well I managed to restore mine to 2.2.1 in the end. But everytime I try anything above 2.2.1 it does the same thing.

    I actually found that the connection to the home button wasn't very good so I couldn't get it into DFU mode. I've since opened it up and pulled the connector out more which made it work perfectly now (I don't recommend this if you don't want to damage your iPod - Very delicate work)

    Anyone know why I (or the other guy) can't install a newer firmware?
    Also, I read about purchasing the new firmware for the iPod. I have never been asked by iTunes/Apple to purchase 3.1 it just tells me it's available.
     

Share This Page