Unable to restore iPhone 4 to 6.1.3 (from 5.1.1)

Discussion in 'iPhone Tips, Help and Troubleshooting' started by chipchen, Jun 3, 2014.

  1. chipchen macrumors 6502

    Joined:
    Oct 30, 2002
    #1
    I have an iPhone 4 that I recently requested an unlock for (and was approved). I would like to update it to iOS 6 so that iMessage at least works. But I don't want to slow it down with iOS 7.

    So I found a few sites to download iOS 6.1.3 and in iTunes, I hold down option while I click restore. I select the IPSW of 6.1.3 and it goes through the motion until I get an error stating that "The iPhone could not be restored. This device isn't eligible for the requested build."

    Do I HAVE TO upgrade to iOS 7? Am I missing a step?

    Any thoughts?

    FULL DISCLOSURE: This was jailbroken and used in Asia for about a year. I also tried "erase all content and settings" and that doesn't work.
     
  2. 53kyle macrumors 65816

    53kyle

    Joined:
    Mar 27, 2012
    Location:
    Sebastopol, CA
    #2
    Yes, you have to update to iOS 7. A quick google/forum search would have told you that.
     
  3. chipchen thread starter macrumors 6502

    Joined:
    Oct 30, 2002
    #3
    I've been searching a lot... What would be the point of all these sites letting people download older version IPSW files then?
     
  4. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #4
    Just because you can download an old Ipsw it doesn't mean you can install it.
    There's a lot more to it than just holding option and select restore.
    You need to research a lot more to understand why and how.
    Start by googling shsh blobs.
     
  5. chipchen thread starter macrumors 6502

    Joined:
    Oct 30, 2002
    #5
    I've done quite a bit of googling... Since I'm starting from scratch, I have no basis of where to go with these searches.. that's why I'm here. Hopefully to save a bit of time and headache...

    What I've learned so far is that Apple stopped signing iOS 6 restores in Sept 2013... I'm here hoping to find a way around that so that I can not have this iPhone 4 running iOS 7. If it's absolutely not possible... okay. If there's a way, and someone knows... and can help me out... I'd greatly appreciate it.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Only if you have saved shsh blobs for that specific device for older iOS versions.
    If not then it's not possible to restore to anything but the latest iOS version for it.
     
  7. chipchen thread starter macrumors 6502

    Joined:
    Oct 30, 2002
    #7
    Can I just save a SHSH blob now as it's on 5.1.1? Will I be able to restore into 6.1.3 with that blob, or only back to 5.1.1?

    ----------

    Also, does anyone run iOS 7.1 on their iPhone 4 currently? My main concern is speed, I could care less about jailbreaking. Are my concerns baseless? Should I just upgrade to 7?
     
  8. Tyler23 macrumors 603

    Tyler23

    Joined:
    Dec 2, 2010
    Location:
    Atlanta, GA
    #8
    You can only save blobs while Apple is still signing that firmware.

    At this point, it's iOS 7.1.1, or staying where you're currently at.
     
  9. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #9
    I dont have an iphone 4 to test it but it shouldn't be that bad on 7.1.1
     
  10. jjfad macrumors member

    Joined:
    Jun 3, 2013
    #10
    I tried iPhone 4 on both ios6 and ios7. Coming from Android I thought both were pretty bad, laggy as heck! I'm now using iPhone 4S on ios7 and it is a more reasonable experience.
     
  11. boostdemon macrumors newbie

    Joined:
    Jul 24, 2014
    Location:
    Cary, NC
    #11
    I too am in the same situation where i have an old (but perfect condition) iPhone4 jailbroken on 5.1.1 that a LOT of the apps i use (banking, fitness pal, etc) are requiring an iOS6+ upgrade now.

    I think i have a pretty good idea how to do this update by stitching an SHSH Blob from device with iOS 6.1.3 into the .IPSW file and then doing the iTunes restore upgrade using the custom file... then re-jailbreaking my phone and installing my apps.

    I can't seem to find any SHSH blobs saved at all in Cydia - aren't they supposed to be automatic when you open it? When i go into the 'TSS Center' all i see on top is; SHSH: iOS5.1.1 and then a link about 'where is my iOS 6.0-6.1.2'.

    How do you look to see what SHSH Blobs you have backed up?
    How do you back up an SHSH blob from the current release to 'hold' until a jailbreak is released?

    I use the tethering app (PDAnet) daily at work so i can't afford to not be jailbroken.
     
  12. boostdemon macrumors newbie

    Joined:
    Jul 24, 2014
    Location:
    Cary, NC
    #12
  13. bbrks macrumors 65816

    bbrks

    Joined:
    Dec 17, 2013
    #13
    Restore to 7.1.2 and jailbreak with Pangu 1.1. I simply see no reason, what so ever, to go to 6.1.3, even if you can fetch SHSH blobs for it.
     
  14. boostdemon macrumors newbie

    Joined:
    Jul 24, 2014
    Location:
    Cary, NC
    #14
    I would think iOS 7 on an old iphone4 (not S) would bring it to a grinding halt most of the time, no?

    Is 7.1.2 still being signed by apple?
     
  15. bbrks macrumors 65816

    bbrks

    Joined:
    Dec 17, 2013
    #15
    7.1.2 is the latest IOS, so yes of course Apple is signing it.
    I have i4 on 7.1.2 jailbroaken, works fine for me :)
     
  16. boostdemon macrumors newbie

    Joined:
    Jul 24, 2014
    Location:
    Cary, NC
    #16
    Cool thanks, i'll give it a go tonight. It seems like a while since there was a jailbreak out for a current IOS i had no idea ;)
     
  17. eyoungren macrumors P6

    eyoungren

    Joined:
    Aug 31, 2011
    Location:
    Phoenix • 85037
    #17
    Since you are doing some research, you might want to look at this. The ball was dropped on blobs for iOS 6.

    You'll note that if you do go up to iOS 7, Apple no longer uses blobs for authentication.
     
  18. boostdemon macrumors newbie

    Joined:
    Jul 24, 2014
    Location:
    Cary, NC
    #18
    yeah thats the hyperlink in Cydia for "wheres my blobs for 6.0-6.1.2". I was hoping 6.1.3 was not part of that fiasco.
     
  19. bbrks macrumors 65816

    bbrks

    Joined:
    Dec 17, 2013
    #19
    Indeed it wasn't, 6.1.3 blobs are OK, but as I told you above, forget ios 6, there in nothing wrong with i4 on 7.1.2 :)
     

Share This Page