Unable to restore iPod Touch (Previous 3.1 firmware)

Discussion in 'iPod touch' started by kAoTiX, Nov 5, 2009.

  1. kAoTiX macrumors 6502

    kAoTiX

    Joined:
    Oct 14, 2008
    Location:
    Midlands, UK
    #1
    I recently purchased an iPod Touch off eBay. It was damaged so I repaired the digitizer no problem.
    It was already on 3.1 firmware but obviously synced to someone elses iTunes so I wanted to do a complete restore on it on 3.1.2

    I plugged it into iTunes and started the restore, but the iPod wasn't doing anything and then iTunes crashed (what luck). So i restarted the process but the iPod wouldn't go directly into recovery mode (reboot loop with apple logo). I thought well forget this so I put the iPod into DFU mode and started over.
    Upon attempting to restore I'm now getting the good old 1604 error message while preparing the iPod for restore.

    I've literally tried everything I can think of to get it to restore but nothing is working. So far I've tried the following:

    Different USB port
    Different PC
    Reinstalling iTunes (plus combination of the above)
    Tried on my mac mini
    Manual restore to a previous firmware downloaded from apple direct (2.2, 2.2.1, 3.0, 3.1.1, 3.1.2)
    Usb cable is directly into the PC/Mac so no hubs involved.
    Also tried iRecovery to manually write to the iPod

    Can anyone else suggest anything? It's literally bricked now and I cannot believe for a second that there isn't a way to restore it as it was working perfectly fine before hand.

    Any help is greatly appreciated.
     
  2. fastrunner macrumors newbie

    Joined:
    Dec 17, 2009
    #2
    kAoTiX - sorry to post on this thread as I dont have an answer to your problem;

    I needed to contact you though please as I see you are West Mids based and repairs - I have my sons ipod touch 1gen with cracked screen which I want to get replaced.

    Please can you contact me via my profile if you are able to help?

    cheers
     

Share This Page