Unable to see or connect to HP wireless printer

Discussion in 'macOS Sierra (10.12)' started by BAH-ras, May 18, 2017.

  1. BAH-ras macrumors newbie

    Joined:
    Oct 2, 2013
    #1
    Hi guys,
    I used to connect to my wireless printer (HP Photosmart B110) OK until Virgin changed my router. Now I can still connect to the Internet and the printer is connected to the same local WiFi network, but my MacBook Pro can neither see nor connect to the printer.

    I'm sure this will be simple, but for now i am stumped - help please.
     
  2. zone23 macrumors 68000

    Joined:
    May 10, 2012
    #2
    Did you check to see if the two are in the same IP address range meaning 192.168.0.1 or 10.10.0.1? My guess is the printer had a static IP on a different IP address range. You would need to go into the printer and set an IP in the range of the new router. That or your Mac is still using the old range I assume you rebooted everything.
     
  3. Art Lynch macrumors newbie

    Art Lynch

    Joined:
    Jul 29, 2017
    #3
    Hello, I am using OS X El Capitan. My Mac is connected to the internet though wireless connection at home. I set up the printer and it is also connected to the same network. I downloaded the HP Easy Start program from HP. Upon hitting My HP Product Setup, there is a check mark next to power on, installation of supplement cartridges, and the sentence saying that in case wireless connection is not used, use usb or ethernet cable to connect the Mac to the printer. I pressed Continued. After searching for awhile, it says that device cannot be found. I tried to add the printer via system preference->printer and scanner, in the first trial the printer name showed up but after resetting the printer, the printer does not show up anymore. Could you please let me know how to fix the problem?
    --- Post Merged, 1 minute ago ---
    Same problem. It worked until an HP upgrade. It worked with all devises even older phones and computers not using El Capitan. Is there a fix. I nee to print remotely. Use laptop, ipad and phones.
     

Share This Page