Unable to select audio outputs (alt click)

Discussion in 'MacBook Pro' started by Ardmanz, May 7, 2015.

  1. Ardmanz macrumors regular

    Joined:
    Jul 12, 2013
    #1
    Most of the time I use my speaker out (or headphones) as my main output source.

    Previously I would plug in my TV (via HDMI) or an audio interface (via thunderbolt) then alt+click on the speaker, select the option and away we go. Now, for some reason, the options don't appear here (it has everything but the device I've just plugged in). If I go to settings the device I've plugged in is in there but clicking it doesn't do anything.

    The only way I can get it to work is to reset my rMBP while the device is plugged in, then it automatically picks up whatever device I have plugged in (it is also now there when I alt+click the speaker icon). When I unplug it I have to reset again to be able to use the internal output.

    This started happening all of a sudden. Any ideas?

    I'm on 10.10.3

    I have tried the killaudio command but that didn't help.
     
  2. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #2
    I also tried a PRAM reset and booting into safe mode (which apparently clears the cache). No deal.
     
  3. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #3
    Now something weird is happening when I plug in/unplug my headphones.

    If I plug them in it works, I can hear sound but I get no control over the volume. The buttons don't do anything (the volume display pops up but doesn't do anything) and if I click on the speaker in the menu bar I can move the slider but the volume doesn't change. If I reset my mac then it works again.

    I've been getting pretty sick with how buggy Yosemite is lately. :(
     

Share This Page