Unable to select audio outputs (opt+click)

Discussion in 'OS X Yosemite (10.10)' started by Ardmanz, May 9, 2015.

  1. Ardmanz macrumors regular

    Joined:
    Jul 12, 2013
    #1
    I posted this in the rMBP forum but I'm not having much luck there. This is probably the more appropriate sub forum.

    Most of the time I use my speaker out (or headphones) as my main output source.

    Previously I would plug in my TV (via HDMI) or an audio interface (via thunderbolt) then alt+click on the speaker, select the option and away we go. Now, for some reason, the options don't appear here (it has everything but the device I've just plugged in). If I go to settings the device I've plugged in is in there but clicking it doesn't do anything.

    The only way I can get it to work is to reset my rMBP while the device is plugged in, then it automatically picks up whatever device I have plugged in (it is also now there when I alt+click the speaker icon). When I unplug it I have to reset again to be able to use the internal output.

    This started happening all of a sudden. Any ideas?

    I'm on 10.10.3

    I have tried the killaudio command but that didn't help.

    I also tried a PRAM reset and booting into safe mode (which apparently clears the cache). No deal.

    Now something weird is happening when I plug in/unplug my headphones.

    If I plug them in it works, I can hear sound but I get no control over the volume. The buttons don't do anything (the volume display pops up but doesn't do anything) and if I click on the speaker in the menu bar I can move the slider but the volume doesn't change. If I reset my mac then it works again.

    I've been getting pretty sick with how buggy Yosemite is lately. :(
     
  2. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #2
    Still not had any luck searching for fixes on google.

    Is there way to uninstall/reinstall the audio drivers (I know this is a very Windows way of thinking but it would be useful).
     
  3. fisherking macrumors 603

    fisherking

    Joined:
    Jul 16, 2010
    Location:
    ny somewhere
    #3
    am not having those issues, and freely switch between a usb audio interface, boomaudio (with the internal speakers), headphones (when i travel), and my tv (thru hdmi).

    & have never option-clicked anything. doesn't seem to actually do anything here.

    have you tried deleting the system prefs preference file? (home>library>preferences). and rebooting?
     
  4. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #4
    Thanks for the suggestion. It didn't work though.

    Is there anything else I can do? I'm worried I'm going to have to format and reinstall OS X which I really want to avoid if possible.
     
  5. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #5
    If I install Yosemite over the top will it leave all my apps/user data alone?
     
  6. Ardmanz thread starter macrumors regular

    Joined:
    Jul 12, 2013
    #6
    Well:

    sudo killall coreaudiod

    in terminal now seems to work. I have to run that command almost every time I insert headphones, TV vida HDMI or my audio interface for them to show up in the options. It's annoying but at least it's slightly quicker than resetting.
     
  7. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #7
    You could maybe try using an app? I use Audioswitcher (there are two apps with similar names, 'Audioswitcher' all one word).
     

Share This Page