Unable to Send Messages

Discussion in 'Apple Watch' started by jpu, Apr 24, 2015.

  1. jpu macrumors member

    jpu

    Joined:
    Mar 1, 2014
    #1
    For some reason I can't send iMessages from my Apple Watch! When I text somebody with an iPhone, it sends as a text message instead of an iMessage. Then, I get a notification that the text message failed to send. Has anybody else experienced this?
     
  2. Daleybhoy macrumors member

    Joined:
    Apr 20, 2015
    Location:
    Scotland
  3. jpu thread starter macrumors member

    jpu

    Joined:
    Mar 1, 2014
    #3
    Make sure that you're signed into iMessage using your Apple ID. I thought that I was, but I wasn't. It works for me now.
     
  4. danielnicklin macrumors newbie

    Joined:
    Sep 27, 2013
    #4
    Same boat! Anybody found a fix??

    ----------

    Actually... If you sign in and out of iMessage, it's should sort it out
     
  5. lewisd25 macrumors 6502a

    Joined:
    Jul 6, 2007
    #5
    This messages issue has been bugging me all day! Do I log out on my iPhone?
     
  6. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #6
    Same here, any solutions? I signed in and out of iMessage on the iPhone but that hasn't changed anything.
     
  7. Slcflier macrumors newbie

    Joined:
    Jun 18, 2014
    #7
    If all y'all have two-step verification turned on, you have to generate an app specific password. I had the same problem. Works great now.
     
  8. Watabou macrumors 68040

    Watabou

    Joined:
    Feb 10, 2008
    Location:
    United States
    #8
    Thank you, I did have 2FA turned on! That indeed fixed the issue for me. For others, here are the steps:


    1. Go to appleid.apple.com
    2. Select "Password and Security"
    3. Click on Generate App Specific Password
    4. Enter "iPhone Messages" or something similar in the "App Name".
    5. Click "Generate".
    6. Keep this window open.

    And now on the iPhone:

    1. Go to Settings -> Messages.
    2. Turn off iMessage.
    3. Turn on iMessage.
    4. In the password field, enter the app-specific password generated above.
    6. That's it!

    Apple Watch will now use iMessages instead of text messages.

    It's pretty weird that there's no information on this and Apple even recommends people turn on 2FA.
     

Share This Page