Unable to set encrypt backup password

doobs

macrumors regular
Original poster
Jul 19, 2008
136
0
I check the Encrypt iPhone backup checkbox and then enter my new password twice. Then it tells me: "The password you entered to protect your iPhone backup file could not be set. Please try again." I try again and get the same error. Any ideas?
 

Marco Lopes

macrumors newbie
Feb 10, 2009
1
0
I've done it just after i upgraded itunes and it was working fine, until it somehow unchecked it self:confused: and now every time i try to check it and enter the same password as before, that message occurs... anyone else having this issue?
 

doobs

macrumors regular
Original poster
Jul 19, 2008
136
0
I eventually "solved" this by completely restoring my iPhone as new, deleting the old backup, and creating a new one with a new password. My iPhone was f'd up anyway with the mixed/missing icon bug. This is probably not the solution you want to hear, but it fixed the problem.
 

C DM

macrumors Sandy Bridge
Oct 17, 2011
48,914
17,550
There is an easier way out on this:
  1. Quit iTunes
  2. Disconnect the iPhone from the USB cable connecting to the computer if it is currently connected
  3. Connect the iPhones Lightning / charging USB cable to the computer, then reconnect the iPhone to that USB cable
  4. Relaunch iTunes
  5. Go to the “Summary” tab for your connected device and click to enable encrypted backups again
  6. Enter the password to set as the encrypted backup password twice as usual, then back up the iPhone as usual
Don't think Lightning connector was around 7 years ago. ;)
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.