Unable to sign into Netflix on Apple TV 3

Discussion in 'Apple TV and Home Theater' started by lightsout, Mar 29, 2012.

  1. lightsout macrumors member

    Aug 26, 2005
    Hey all,

    Just wondering if anyone else has seen this problem - I've had my Apple TV 3 for a week and I am unable to sign into Netflix on it ever.

    My internet connection is fine (I can stream 1080p direct from Apple), I've deactived all devices in Netflix, I've changed my password in Netflix too. I've tried using the Apple remote app just to copy'n'paste my password in directly, but nothing works.

    Anyone seen this? Any ideas?

  2. b-rad g macrumors 6502a

    b-rad g

    Jun 29, 2010
    No problem here. Was watching old episodes of Top Gear last night.
  3. machpost macrumors 6502


    Jan 28, 2010
    Washington, DC
    I haven't had any problems with my ATV3, but since updating my ATV2 to the new software version, I've been kicked off Netflix twice. And that has never happened before. I also deactivated all my devices while troubleshooting, but still got kicked off and had to log in again a few days afterward.
  4. OllyW Moderator


    Staff Member

    Oct 11, 2005
    The Black Country, England
    I had a problem signing in using the Remote app. I tried about 6 times but it kept refusing the password. I phoned Netflix support and they even re-set the password for me but I still had no luck.

    Eventually I tried the supplied Apple TV remote and it worked 1st time for me. It's worth giving it a go.
  5. mic j macrumors 68030

    Mar 15, 2012
    I keep getting "Netflix is not available" and then a 3 digit error code.
  6. lightsout thread starter macrumors member

    Aug 26, 2005
    Ok well I attached it to ethernet instead of wifi and typed it all in by hand on the Apple TV remote and it worked. No idea what was going on there!
  7. Ducklin macrumors newbie

    Dec 4, 2012

    I have had the same problem. I bought the latest appleTV last Friday and first Netflix was working fine. Then I updated the software of the AppleTV and the connection just wont work again.

    The weird thing is that I bought the WiiU today which also has Netflix and that didnt work either. The network works in both cases as I can connect to my friends on WiiU and strean movies from the AppleTV. Netflix works well also with Mac, iPad and iPhone in the same network.

    I just wonder what is the problem there...

Share This Page