Unable to Test Apps on iPod Touch [Error]

Discussion in 'iOS Programming' started by El-Presidente, Jul 29, 2009.

  1. El-Presidente macrumors newbie

    Joined:
    Jun 16, 2009
    #1
    Hi, I'm having some trouble getting the last steps of being able to connect my laptop to my iPod touch by sending the app to it.

    All of the IDs and keys have been created and work, including my Provisioning Profile, which is connected in the XCode > Organizer. When I use the organizer to add the app, it says: "The application could not be verified." I clearly have the correct key, and it says that it is in Keychain Access too.

    When I try and just sync the iPod Apps in iTunes, it also says it can't be verified. I have no idea why not, but could someone point me in the right direction?
     
  2. moral-hazard macrumors regular

    Joined:
    Jul 27, 2009
    Location:
    Palo Alto, CA
    #2
    Apple provisioning for the iPhone is awful. Every once in a while, things just get totally jacked up and it won't install.

    Getting an iPod compile for the first time never seems to go correctly. All of the following have worked for me (at some point) when the device wouldn't compile.

    1.) Reset the device (turn it all the way off, then back on)
    2.) Double check all of your certificates & the provisioning profile. There are like 3-4 'things' you need.
    3.) Reboot XCode
    4.) Re-download and re-install the provisioning profile
     
  3. El-Presidente thread starter macrumors newbie

    Joined:
    Jun 16, 2009
    #3
    I tried this all like you said, but it still isn't working. I then went on the Apple Dev site and looked at other people with this issue, tried their resolutions, but didn't work. Why the **** does every person have this problem?

    Any ideas?
     
  4. El-Presidente thread starter macrumors newbie

    Joined:
    Jun 16, 2009
    #4
    SOLVED IT! YESSSSS!

    I think the issue was I was missing the ultimate apple certificate, but when I installed it at first it didn't work. I deleted everything and started from scratch on setting up the ID, so it worked after!

    YUSSSS :)
     

Share This Page