Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

iPhone Unable to text my wife with iMessage (Blue)

StarShot

macrumors 65816
Original poster
Mar 31, 2014
1,013
371
Not sure to know exactly how to ask this question. I'm outside the country, US, and down in Australia. I can text friends with iPhones back in the US with no problem (iMessages). However, I can't do the same with my wife's iPhone and a few others also. IF i enter her number, the message defaults to an SMS message. (Green). If instead, I use her email address, the messages go out as iMessages.

I assume there must be some setting in either her directory or mine that's causing this problem. I should note I'm using an Australian sim card, but as I said above, I don't have this trouble with others in my directory.
 

Banglazed

macrumors 68040
Apr 17, 2017
3,543
4,109
Cupertino, CA
Have you tried to see if you can FaceTime your wife or those others? Is it only iMessage? Are you signed into your iCloud account to use your iCloud email and phone number? Turn off iMessage and FaceTime and turn them back on?
 
Comment

d123

macrumors 68020
Oct 19, 2009
2,063
477
Earth
Is iMessage active on your wife’s phone for her phone number?

Or on the other phones you’re having problems with.
 
Comment

StarShot

macrumors 65816
Original poster
Mar 31, 2014
1,013
371
Is iMessage active on your wife’s phone for her phone number?

Or on the other phones you’re having problems with.

Yes, it is on my wife's phone. I assume it on for other phones I CAN iMessage to. On her phone it says "you can receive iMessages to and reply from xxx.xxx-xxxx. However, that number is grayed out although it does have a "checked" mark.

On my phone under the same menus, my phone number is NOT grayed out.
 
Last edited:
Comment

Enjoylife1788

macrumors 6502a
Aug 22, 2011
800
109
Yes, it is on my wife's phone. I assume it on for other phones I CAN iMessage to. On her phone it says "you can receive iMessages to and reply from xxx.xxx-xxxx. However, that number is grayed out although it does have a "checked" mark.

On my phone under the same menus, my phone number is NOT grayed out.
Yes that used to happen long time back. There was some bug. What you would need to do is ask your wife to disable imessage completely for a couple of hours and then turn back on. That would resolve the issue.
 
Comment

StarShot

macrumors 65816
Original poster
Mar 31, 2014
1,013
371
Yes that used to happen long time back. There was some bug. What you would need to do is ask your wife to disable imessage completely for a couple of hours and then turn back on. That would resolve the issue.
Thanks, I'll give that a try...
 
Comment

mattyboy7110

macrumors member
Sep 15, 2008
46
14
Is your wife’s number in your phone in international format (+1)? Maybe it’s getting confused with an Australian number?
 
Comment

uniquexoxo

macrumors 6502
Aug 27, 2018
442
306
South East Asia
Hello if this hasn’t been resolved, make sure that on your wife’s messages settings it only set to her number to send and receive messages to. It is really greyed out because the mobile number is default.
 
Comment

StarShot

macrumors 65816
Original poster
Mar 31, 2014
1,013
371
Is your wife’s number in your phone in international format (+1)? Maybe it’s getting confused with an Australian number?

Shouldn't have anything to do with my "former" Australian number which I just removed. With it in the phone, I didn't have any trouble with others texting out or in.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.