Unable to turn on home sharing - iPad2

Discussion in 'iPad' started by thomapa1, Aug 3, 2012.

  1. thomapa1, Aug 3, 2012
    Last edited: Aug 3, 2012

    thomapa1 macrumors newbie

    Joined:
    Nov 10, 2010
    #1
    I have an iMac with OSX 10.6.8, iTunes 10.6.3 - everything is up to date.
    Home networking is using my wireless router - Cisco Linksys E4200.

    Home sharing is turned on as I also have an Apple TV2 that works fine - all using the same Apple store ID and password.

    iMac sharing has File Sharing turned ON
    iPad can connect to wireless network (can get on internet, email, Apple Store), can sync to iTunes via wireless.

    When I try to access my iMac iTunes library for videos and music - the iPad tries, then kicks me back out to the main screen. It sees my shared library, tries to connect, but cannot establish a connection. Error message = "Unable to Turn On Home Sharing"

    I tried the Troubleshooting steps in the knowledgebase including wiping network setting from iPad and redoing, rebooting wireless router while iPad was on, firewall turned off on the iMac, turning off/on Home Sharing on iMac. All devices are on my home 192.168.1 x subnet

    So in a nutshell - Home Sharing works to my Apple TV2 but not my iPad2.

    help!
     
  2. thomapa1 thread starter macrumors newbie

    Joined:
    Nov 10, 2010
    #2
    Found the problem after working with support and trial and error. Turned out that my iTunes library had a problem. Recreated a new itunes library with just a few songs in it - worked OK. After I imported all of my music - it screwed up again. New library and I pulled in sections of artists and re-tested until I found the problem. Looks like I had some corrupt songs from one artist. Deleted the files and source data - all is well now. Weird.
     

Share This Page