Unable to uninstall "Plex Media Server."

aerlenbach

macrumors newbie
Original poster
Feb 8, 2011
16
0
A few months ago I downloaded "plex" to my MBP. I thought it was neat, but wasn't something that I wanted on my primary machine. So, I threw away the Plex application. However, every time I restart my machine, "Plex Media Server" opens up. Obviously it's useless without "Plex," so I just ignored it.
Then I installed Lion. (I dunno if this might have something to do with the problem)
Now. I want to remove "Plex Media Server" because it's annoying, and useless, and I'd rather rid myself of the problem forever. So, I looked onto the Plex site, and it says this...

To completely remove the Plex Client and Plex Media Server from your Mac OS Computer:

Make sure the Plex Client and Plex Media Server are not running
Delete the following Files and Folders:
/Applications/Plex.app
~/Library/Application Support/Plex
~/Library/Application Support/Plex Media Server
~/Library/LaunchAgents/com.plexapp.mediaserver.plist
~/Library/Preferences/com.plexapp.plexmediaserver.plist
~/Library/Preferences/com.plexsquared.Plex.plist


Making it simple for me, of course.
The only problem is, I checked all of those folders in my library folder, and nothing with the name "Plex" or "plex media server" is in the folders. They're just not there. I've searched, I promise. I'll take a picture of all of these folders and put it in the thread if requested. So my question is, how can I uninstall something that my computer claims doesn't actually exist?
 

hleewell

macrumors 6502a
Oct 22, 2009
543
62
A few months ago I downloaded "plex" to my MBP. I thought it was neat, but wasn't something that I wanted on my primary machine. So, I threw away the Plex application. However, every time I restart my machine, "Plex Media Server" opens up. Obviously it's useless without "Plex," so I just ignored it.
Then I installed Lion. (I dunno if this might have something to do with the problem)
Now. I want to remove "Plex Media Server" because it's annoying, and useless, and I'd rather rid myself of the problem forever. So, I looked onto the Plex site, and it says this... So my question is, how can I uninstall something that my computer claims doesn't actually exist?
In Finder, click Go>Go to Folder... and type ~/Library. In Preferences folder, look for com.plexapp, and obliterate those m*$#@f#$%#%%rs. Now you will have Peace my friend.
 

GGJstudios

macrumors Westmere
May 16, 2008
44,360
701
In Finder, click Go>Go to Folder... and type ~/Library. In Preferences folder, look for com.plexapp, and obliterate those m*$#@f#$%#%%rs. Now you will have Peace my friend.
Deleting only the .plist will not remove all remnants of the app. There are many other files/folders beyond that which you find in the Preferences folder. The link I posted will show you how to find them all.
 

deafgoose

macrumors regular
Oct 20, 2011
228
3
I use a program called CleanMyMac to uninstall programs.

So far its worked really well for me.
 

GGJstudios

macrumors Westmere
May 16, 2008
44,360
701
I use a program called CleanMyMac to uninstall programs.
In most cases, app removal software, including CleanMyMac, doesn't do a thorough job of finding and removing files/folders related to deleted apps. For more information, read this.

One app that I would not recommend, based on the number of complaints that have been posted in this forum and elsewhere, is CleanMyMac. As an example: CleanMyMac cleaned too much.
 

tootall

macrumors regular
Apr 17, 2011
212
3
Quebec, Canada
Files in ~/library are hidden?

I had the same problems and solved it following the advices in this thread -- thank you!!!

But I still have two general questions:

1) I searched for plex and the "finder" did not identify any files. Can the finder look in all directories or some are hidden?

2) I even looked manually and did not find the files until I realized that Plex was running; are the files in the library hidden when the app is running?

Thanks
 

GGJstudios

macrumors Westmere
May 16, 2008
44,360
701
1) I searched for plex and the "finder" did not identify any files. Can the finder look in all directories or some are hidden?
2) I even looked manually and did not find the files until I realized that Plex was running; are the files in the library hidden when the app is running?
Did you follow all of the steps in the link in post #2 of this thread? Pay particular attention to steps 5-7.
 
Last edited:
Nov 28, 2010
22,668
27
located
I was having the same issue, not able to locate the Plex source files. That was until I came across an article that indicated that /Library is hidden by default in LION. The process to correct this as follows:

chflags nohidden ~/Library

Source: http://hints.macworld.com/article.php?story=20110704093233123
And the search method laid out by Mister GGJstudios circumvents that, thus you don't need to resurrect, ahem, make the Library folder visible.
 

Mal

macrumors 603
Jan 6, 2002
6,253
17
Orlando
I was having the same issue, not able to locate the Plex source files. That was until I came across an article that indicated that /Library is hidden by default in LION. The process to correct this as follows:

chflags nohidden ~/Library

Source: http://hints.macworld.com/article.php?story=20110704093233123
Unnecessary, unless you're going into the Library repeatedly (which would probably indicate that you're doing something that's not really a good idea), plus each OS update is likely to wipe out that setting. Easier to simply hold option and click the Go menu, or place a shortcut in your sidebar, neither of which will be altered by updates. As GGJstudios said, his method also negates the need for this.

jW
 

swordfish5736

macrumors 68000
Jun 29, 2007
1,897
104
Cesspool
Did you try going to system pref-> users -> login items
And remove plex from there? It should been removed with all the deleting you have done but maybe it's still there
 

GGJstudios

macrumors Westmere
May 16, 2008
44,360
701
Did you try going to system pref-> users -> login items
And remove plex from there? It should been removed with all the deleting you have done but maybe it's still there
The method in post #2 would remove that item, along with everything else related to the app. There's no need to navigate to any specific folder, as the search will find all app components, wherever they are located.
 

RWinOR

macrumors 6502
The method in post #2 would remove that item, along with everything else related to the app. There's no need to navigate to any specific folder, as the search will find all app components, wherever they are located.

I too have a problem with Plex loading when I boot. I have tried all the suggestions and still cannot find it anywhere? I tried looking in finder, I tried spotlight, The full deletion in post 2 and this one. Plex is not listed anywhere yet it always opens.

I have updated to Mountain lion but I had this issue with lion too. Finally getting tired of it.

Any other suggestions?

Thank you
 

GGJstudios

macrumors Westmere
May 16, 2008
44,360
701
I too have a problem with Plex loading when I boot. I have tried all the suggestions and still cannot find it anywhere? I tried looking in finder, I tried spotlight, The full deletion in post 2 and this one. Plex is not listed anywhere yet it always opens.
Complete steps 1-7 of those instructions in post#2, then take a screen shot of your Finder window and post it.
 

epley

macrumors newbie
Jan 27, 2013
1
0
Fixed

The most effective method for complete app removal is manual deletion:
I had the same problem with the evil app pled--everything was hidden--the full app, preferences, etc. Evil. These directions fixed the problem! Thank you!

----------

Complete steps 1-7 of those instructions in post#2, then take a screen shot of your Finder window and post it.
The plex files are hidden. You must follow GGJStudios' directions, and click the plus button, add "other" search criteria for file visibility and choose visible and invisible. It will miraculously show up--all of it.
 

Paha_Keisari

macrumors newbie
Nov 6, 2015
1
0
Länsi-Turunmaa, Suomi
I too have a problem with Plex loading when I boot. I have tried all the suggestions and still cannot find it anywhere? I tried looking in finder, I tried spotlight, The full deletion in post 2 and this one. Plex is not listed anywhere yet it always opens.

I have updated to Mountain lion but I had this issue with lion too. Finally getting tired of it.

Any other suggestions?

Thank you
Hello there. I had the exact same problem. Couldn't find the files, tried to unhide the library and so on. Finally I realized that I was looking at Macintosh HD/Library (I thought this was logical) and was supposed to be looking at User/Library instead! There I found all the files as described here earlier. I hope this will help you :)