Unable to update iPad apps

Discussion in 'iOS 6' started by rockitdog, Jul 26, 2013.

  1. rockitdog macrumors 68020

    Mar 25, 2013
    My kids have taken over my iPad but I just noticed that tonight that the App Store app had the number 17 showing on the badge app. So I went do update all of the apps and even though it shows I have 17 updates to run, when I go into update nothing happens. The screen is blank. Any ideas what is happening?
  2. aPple nErd macrumors 68030

    aPple nErd

    Feb 12, 2012
    Jailbreaks/IOS Hacks
    hold down home and power until the apple logo shows on a black screen, then it will restart, and should fix the problem.
  3. Conan86 macrumors 6502

    Apr 9, 2012
    happening to me too. did several troubleshooting but all doesn't seem to work. might be server side issue.. the following was what I've done but did not solve the issue:

    1. Restart App Store (closed all apps from multitask bar)
    2. Power + Home button restart
    3. Sign out of App Store, logged in with several accounts (of different countries)

    Gonna wait and see if it will self resolve after a while
  4. mrtune macrumors 6502a

    Jun 23, 2007
    This is happening on my ipad 2.

    Restart don't work. Reset didn't work. Closing out the app in multitask tray didn't work.

    I'll give it a few more days. I suspect it's an apple server issue as well.
  5. identity macrumors 6502

    Nov 18, 2011
    That doesn't work for me. I tried that yesterday but still the same problem. I thought it might have something to do with some of my jailbroken apps but after uninstalling them, the problem still exists so it's not cydia related.
  6. smg30 macrumors newbie

    Jul 9, 2010
    Having same problem with updates on iPad 2

    I'm having the same problem updating apps on my iPad 2. Badge shows updates available but AppStore screen doesn't show the apps to update. Tried restart, reset but doesn't change. As a work around, if you know what apps have an update, you can search the store for the app and it will let you update from there. I'm assuming this is an Apple thing at the moment. My iPhone 5 updates fine.
  7. tom123 macrumors regular


    Apr 9, 2006
    Apple server

    It's happening to too many people, so must be on the server side.

    I wonder if Apple Employees work on the weekends.
    Or is it like 40 hours a week like the rest of us.
  8. Donia330i macrumors regular

    Jan 24, 2013
    Happening to me too! iPad 2 as well. I was able to update my apps by connecting to my Mac and updating that way. I wonder what's going on.
  9. Donia330i macrumors regular

    Jan 24, 2013
  10. turbato macrumors newbie

    Dec 24, 2010
  11. Donia330i macrumors regular

    Jan 24, 2013
  12. mrstefani macrumors newbie

    Sep 23, 2011
    Macomb, Michigan
    I've had this issue for the last several days. i can only update apps while plugged into computer via USB cable and syncing. Need a fix for this, plugging into computer daily is not convenient.
  13. bowlerman625 macrumors 68020


    Jun 17, 2009
    Chicago, IL area
    I spoke to Apple tonight about this. It's an issue that has been going on since the Weekend. The rep said Apple is working on a solution other than the manual process of updating the apps one at a time manually.
  14. raccoonboy macrumors 6502a

    Oct 22, 2012

    Never a good idea to do a soft reset just because of that. Better to relaunch the app by closing it in the multitasks.
  15. Conan86 macrumors 6502

    Apr 9, 2012
  16. RedOrchestra Suspended

    Aug 13, 2012
    Well, if still isn't working - go to Purchased, it'll show updates and you'll be able to update from there!

Share This Page