Unable to update Yosemite from Mac App Store

Discussion in 'OS X Yosemite (10.10)' started by rxslim, Sep 2, 2014.

  1. rxslim macrumors newbie

    Joined:
    Apr 4, 2013
    #1
    Is there a way that I am not aware of to update OS X Yosemite? If I go to the Mac App Store, per usual updates, I click the update button it starts to think for a second then reverts back to having the ability to click the update button again, like nothing happened. Please any advice would help thanks.
     
  2. x3n0n1c macrumors regular

    Joined:
    Jul 9, 2014
    #2
    Did you install the recovery portion first? I needed to restart after installing this before clicking update on DP7 would actually update.
     
  3. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #3
    How did you upgrade to Yosemite? Did you install from the App Store in the first place or did you install from an installer you got from somewhere else?

    Also are you running the Public Beta or the Developer Preview?
     
  4. rxslim thread starter macrumors newbie

    Joined:
    Apr 4, 2013
    #4
    I downloaded Yosemite from the Mac App Store, I believe. Through the Apple email. I honestly do not know if I installed the Recovery portion. Sorry.

    Public Beta
     
  5. x3n0n1c macrumors regular

    Joined:
    Jul 9, 2014
    #5
    As the 7th Developer Preview came out today I assumed you were referring to it. If this isn't the case, ignore my previous question.
     
  6. rxslim thread starter macrumors newbie

    Joined:
    Apr 4, 2013
    #6
    Yea. It's not letting me update any Apps. Numbers has been trying to down load for like a week. I have tried restarting. The most recent backup is on the 3rd of last month, which when I first installed Yosemite. Any suggestions would be great.
     
  7. mmomega macrumors demi-god

    mmomega

    Joined:
    Dec 30, 2009
    Location:
    DFW, TX
    #7
    restart your computer and then immediately try to update those apps.
     
  8. AlaricRiver macrumors newbie

    Joined:
    Jun 18, 2014
    #8
    Tried it. Doesn't work.
     
  9. j800r macrumors regular

    Joined:
    Jan 5, 2011
    Location:
    Coventry, West mids, England
    #9
    I'm on beta 2 myself and can't replicate this issue. I had an update the moment I had installed in fact.

    My advice? File it to Apple and sit tight. It's a beta. You're gonna get bugs. In fact as a beta tester you should be happy when you find a bug as that's what you're running it for. I've only found one slight glitch myself since installing and it's almost rather disappointing tbh cause i'm unable to help Apple beta test their product.
     
  10. blwinters macrumors newbie

    blwinters

    Joined:
    Sep 21, 2014
    #10
    I'm having the same problem. It will let me click the Update All button, but not the Update button next to Yosemite Beta 3, though nothing happens despite it showing that I clicked Update All.

    I can see in the update history that it did download the Recovery update yesterday, but I remember having this same problem before that and I don't remember seeing the update happen.

    I've sent feedback to Apple, but no reply yet.
     

Share This Page