Unable to Verify/Repair Time machine backup drive :(

Discussion in 'Mac Accessories' started by niemo810, Aug 24, 2008.

  1. niemo810 macrumors member

    Joined:
    Apr 26, 2007
    #1
    Hello all,

    Yesterday I noticed that my computer had been trying to complete a backup for quite awhile... Well it turns out that it was only a 382KB backup and it was taking hours. I tried clicking "Stop backing up" and nothing happened. The drive was in a repetitious clicking rhythm, and when I tried to eject it, Finder said it was in use. I put my 10.5.2 install disk in and ran Disk Utility. I have two partitions on that drive, Beta and Charlie. Beta verified and repaired without a glitch, but my time machine partition, Charlie, said "Invalid node structure, volume check failed." Also, disk utility was unable to calculate how much space remained on that partition.

    What should I do?

    Thank you,
    Rob
     
  2. Jacquesass macrumors regular

    Joined:
    May 6, 2003
    #2
    I had the same thing happen recently on a partitioned WD 1TB MyBook Studio. Time Machine failed during a backup, the slightly terrifying clicking sound began, and Disk Utility said that partition was unrepairable (and the other partition was OK).

    Nothing I tried was able to repair that partition (which only held a SuperDuper backup and Time Machine backups), including the latest version of DiskWarrior. I eventually reformatted that partition and everything is back to normal (including never hearing the clicking sound again).

    Wish I had better news for you.
     
  3. niemo810 thread starter macrumors member

    Joined:
    Apr 26, 2007
    #3
    That's alright, I think it just has something to do with the black cloud that follows me around.

    I'm used to hard drive problems. The MacBook I bought in August 2007 blew through four hard drives in about eight months. The third time it crashed, Apple gave me Leopard retail for free. The fourth time it crashed, Apple replaced the computer and gave me 3 years AppleCare.

    Well, I suppose I'll just format the disk and move on with my life. I hope I didn't need anything in my time machine. Hey, if I deleted it I probably didn't need it in the first place :rolleyes:

    Thanks for the response, even though it wasn't the best of news!
     
  4. ddorman macrumors newbie

    Joined:
    May 20, 2009
    #4
    I have got a bit of a black cloud too.. my iMac G5 is on it's 3rd logic board :eek:. I won't even list all my other troubles... but lately after I did the 10.5.7 update, I've been getting problems were apps will hang while time machine is running, and it seems to be running forever. Also, when the computer is on a screen saver, and I go to log back in, if TM is running (I assume this because my external TM drive's lights are spinning) I just get a black screen with a mouse cursor for however many minutes until finally the screen saver comes back and then it usually gives me the log in window. I decided that I was going to restore my system from the TM drive to before I did the OS update, however Safari had froze, and then the dock trying to force quit Safari, and then anything I tried to force quit from the apple menu froze so I eventually just held the power button in to restart. I told TM to stop backing up but it never go anywhere. So after the reboot, my firewire TM drive won't mount, and I finally get it to show up in Disc Utility and it can't repair the drive. I am getting all those same errors you are. I am really going to be bummed out about this, because I had backed up my previous system on this drive and not copied all my files back over...

    did this just start happening to you after the 10.5.7 update by chance? Googling though, it does appear this is somewhat of a common TM/OS X problem since Leopard came out.
     

Share This Page