Unable to view ANY YouTube content on Apple TV ...

Discussion in 'Apple TV and Home Theater' started by Cockney Rebel, Oct 21, 2012.

  1. Cockney Rebel, Oct 21, 2012
    Last edited: Oct 21, 2012

    Joined:
    Sep 10, 2012
    #1
    "No content was found

    There is a problem connecting with YouTube. Try again later"



    ... this is the message I am getting when I try to access ANY YouTube content (most viewed, latest etc).

    Unable to log into my YouTube account, either (tried 2 accounts). It either says "This account cannot be used with Apple TV. Try again using a different account" or it tells me that the username or password is incorrect.

    Was working perfectly before I restored the Apple TV yesterday as I was having problems accessing my favourites in the Podcast app (was stuck on "accessing account" with the spinning wheel) but this works perfectly now (I believe it was a rogue favourite which was lurking about in the podcast app on my iPad, which I have now managed to delete).

    Anyway, everything appears to be working as expected now except the YouTube app which will simply not show anything, or allow me to sign in (as I said, I have tried two different YouTube accounts ... one being a Gmail account and one being my older Googlemail account).

    It is an Apple TV 3, by the way.

    Has always worked perfectly and even yesterday (before I restored it for the first time - I have now restored it 3 times in the hope of "ironing out" any possible glitches) I was able to access YouTube without problems.

    But now ... no YouTube content at all?

    Are you experiencing the same issue?

    Any help/advice would be really appreciated as YouTube was basically the reason for me buying Apple TV in the first place.

    Thanks in advance.



    ... to add to this, I just created a Vimeo account and I was able to log into it on my Apple TV instantly, without any problems whatsoever. I can also view all content on Vimeo, regardless of whether I'm signed in or not. So it really does look like everything else works just fine on my Apple TV and it's just YouTube which is playing up?
     
  2. NeroAZ macrumors regular

    Joined:
    Jun 23, 2009
    Location:
    Phoenx, AZ
    #3
    I would check network settings, and if they are okay, pull the plug and reset the apple tv. usually works for me.
     
  3. Cockney Rebel thread starter Guest

    Joined:
    Sep 10, 2012
    #4
    Hello there.

    I appreciate you taking the time to respond, but as I have said I have already completely restored the device (to new) 3 times, but this has not sorted it.

    Network settings are all ok, and I can access other stuff on the Apple TV so I'm quite confident that it's not a network issue.

    Have you experienced these issues yourself? Specifically, these error messages?

    Thanks again ...
     
  4. macleod199 macrumors 6502

    Joined:
    Mar 10, 2007
    #5
    Have you looked in your Google settings? There may be some sort of account setting issue.
     
  5. Cockney Rebel thread starter Guest

    Joined:
    Sep 10, 2012
    #6
    Thanks for the input.

    I have adjusted many setting but nothing appears to sort it.

    I've even created new accounts but they are still not working with the Apple TV.

    I have Googled the issue and apparently people have experienced it all over the world and it simply "started working" again after a period.

    It simply has to be an issue with YouTube itself because:

    1: everything else works perfectly

    2: NO content is accessible. I'm not just talking about not being able to log into my account, I am saying that I can't view any content whatsoever (most viewed, most recent etc)

    I have reset the device 4 times in total now and I'm not doing it anymore. I'll just see if it starts working again over the next couple of days.

    I'll Apple tomorrow, too. I actually called them this morning but apparently tech support is only available for iPhones on a Sunday over here in the UK!

    Thanks again ...
     
  6. Cockney Rebel thread starter Guest

    Joined:
    Sep 10, 2012
    #7
    Sorted!

    So this thing has been driving me nuts since about 4am and I've been at it all day but I've finally found the issue!

    After much digging through the internet it appears that maaaaany people have/are experiencing this problem and one person shared the answer.

    There appears to be a bug with regards to the YouTube app and Ethernet. Basically, all I had to do was disconnect the Ethernet cable from the the Apple TV, then reset settings, then connect via WiFi, and after this I could access YouTube perfectly and signing into my account was instantaneous.

    After doing this I reconnected the Ethernet cable and all is once again working perfectly.

    This glitch has probably been there for a while because I only got this Ethernet cable a few weeks back so when I initially set up the the Apple TV when I first bought it I would have been using WiFi.

    This is a great tip for anyone who may be having any account issues with their Apple TV's ...

    PS, to look on this in a positive way I can now see just how much I appreciate my Apple TV ;)

    Also, I think I will now be getting into Vimeo which I never bothered with before so this is another plus which has come out of the whole situation ...
     
  7. TechnikLayman macrumors newbie

    Joined:
    Oct 3, 2011
    #8
    Thanks man, this just worked out for me. I singed in using WiFi and the reconnected the Ethernet cable... Crazy Bug :eek:
     
  8. macleod199 macrumors 6502

    Joined:
    Mar 10, 2007
    #9

    That's some pretty sweet problem solving.

    Vimeo also seems to have some pretty cool content. Although I briefly got it confused with Vevo, which would be even more exciting - what with all the official music videos. Apparently you can mirror it from the iPad app, but I haven't tried it yet.
     
  9. Cockney Rebel thread starter Guest

    Joined:
    Sep 10, 2012
    #10
    You're welcome, bud.

    Glad it sorted it for you.

    ;)

    ----------

    ... it's called AirPay and you can "push" content from your iOS device to your Apple TV.

    This can be done while multitasking, too, so while your iPad is streaming video to your Apple TV you can switch to Safari and brows the web at the same time.

    Or you can use another app :)
     
  10. FatCatElvis macrumors newbie

    Joined:
    Feb 29, 2012
    #11
    Worked perfectly. Thanks.


    Was strange. Youtube app on AppleTV was working fine before, then one day, none of the videos would stream (just showed an endless circle wheel). Same problem when trying to Airplay a Youtube video from iPad Mini and iPhone.

    After disconnecting the Ethernet, resetting Apple TV 3 (btw), reconnecting via wifi, everything works perfectly now. Haven't yet reconnected the Ethernet cable yet. Not sure if I even need to since my wifi speed is pretty darn good and I don't notice any performance issue right now.
     

Share This Page