Unable to write to NFS in finder, ok in shell

Discussion in 'Mac OS X Server, Xserve, and Networking' started by costabunny, Nov 8, 2008.

  1. costabunny macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    ~/bunny/
    #1
    I have a NAS runnign NFS. All Linux and windows users can write to it through there file managers. The Macs will not. I can write via shell (which is ok as I love my shell), but I am putting the Mini in the lounge and I'd like to fix this.

    The export is /volume1/public 10.10.10.1/24(rw,no_wdelay,no_root_squash,insecure,anonuid=501,anongid=100)

    (I also have the issue that the Mac writes at 4MB/s max in shell (yet win/linux can write at 35MB/s)

    Read speed is fine at 60MB/s

    Is there anything I can do here? (I tried to increase the threads for nfs but the method i find is depricated)
     
  2. foshizzle macrumors regular

    Joined:
    Oct 17, 2007
    #2
    how are you mounting the share on your mac? Are you using Directory Utility.app to mount the share automatically?

    I had this problem a few weeks ago after trying to connect to my new Solaris server over NFS. Your Options look fine on the share. What OS are you using on the NAS?

    When you Command-K in the finder, do you use:
    nfs://servername:/share/here
    Make sure to use the colon after the servername. (you do not need this, however, when mounting via director utility.)
     
  3. costabunny thread starter macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    ~/bunny/
    #3
    Being a unixy person, I typically mount from the cli:

    mount -t nfs -o rw 10.10.10.10:/volume1/public /mnt/public/

    I also tried it from finder with:

    nfs://10.10.10.10:/volume1/public

    I am unable to drag'n'drop with either (but using a shell is fine) :(

    The NAS is running BusyBox (Linux BALTAR 2.6.24 #722 Sat Sep 20 00:41:32 CST 2008 ppc)
     
  4. costabunny thread starter macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    ~/bunny/
    #4
    syslog is saying:

    Nov 9 02:23:20 starbuck kernel[0]: portmap 574 FS_READ_DATA SBF /private/etc/hosts.allow 13 (seatbelt)
    Nov 9 02:23:20 starbuck portmap[574]: warning: cannot open /etc/hosts.allow: Permission denied
    Nov 9 02:23:20 starbuck kernel[0]: portmap 574 FS_READ_DATA SBF /private/etc/hosts.deny 13 (seatbelt)
    Nov 9 02:23:20 starbuck portmap[574]: warning: cannot open /etc/hosts.deny: Permission denied

    (both files exist and are world readable.... :(
     
  5. costabunny thread starter macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    ~/bunny/
    #5
    NO OnE :( I am a sad Bunny....

    I am sure its the mount on the NAS as my Solaris box exports and I can chuck stuff at the share via the GUI in Mac OS with no issues (and damn is it fast - I LOVE ZFS)....

    So... I think maybe stuff the NAS and ill go get me some bits and shove all my disks in the solaris machine and use that instead!

    Anyone wanna buy a pretty linux based NAS box ???? ;)
     
  6. ChrisA macrumors G4

    Joined:
    Jan 5, 2006
    Location:
    Redondo Beach, California
    #6

    "/etc/hosts.allow: Permission denied" That sure sounds like something that needs to be fixed. You must have edited it as the "wrong" user.

    In these cases where you can read but not write the NFS it's almost always a permissions problem. But remember it is based on UID and your UID on each system may not be the same. So look that if you are "502" on the client that you are also 502 on the NFS server and write is open to 502.

    Chaeck groups too. Maybe you are a member of some group on the client but not on the NFS server.

    When I did this with a whole lab full of computers I just user an NIS password and group maps rather than /etc files. Today LDAP is in style for that kind of stuff. But with just two computers just copy the files with FTP.
     
  7. costabunny thread starter macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    ~/bunny/
    #7
    Yes i did check the permissions (users/groups exist and are the same accross all my systems in the house) the permission denied on /etc/hosts.deny / allowed are world read and root write anyways (it doenst change whether I explicitly add the hosts or leave them empty) :(

    And I can write to the NFS no problems - its finder that cant :( (I use the cli most of the time). Interesting is that the solaris NFS server is fine, just the diskstation and both have the same exports for their respective nfs shares.

    bizarely finder has no problems writing to the solaris nfs so I am suspecting the diskstations export but I cant see anything wrong...... I really do think I am going to build the solaris box to be my nfs server, but thisis such a silly problem and my teeth are in it now that I would like to resolve it :)
     
  8. foidulus macrumors 6502a

    Joined:
    Jan 15, 2007
    #8
    EDIT:I saw you said Windows users are connecting fine, that probably indicates that it is sharing out SMB.

    The NFS server doesn't share out any files via any other protocol(namely SMB) does it? We had a problem with our Leopard boxes mounting a file server as SMB instead of NFS(We told it to mount NFS via the fstab, the SMB was only supposed to be for windows machines) It was the same issue, we could read/write to the share via the Terminal, but Finder wouldn't let us access the server(it appeared as a BSOD in the Finder sidebar)

    We even contacted Apple Enterprise support through the contract we payed out the nose for, and they were useless.

    We fixed it by only allowing the Windows machines to connect by changing the smb.conf file.
     
  9. costabunny thread starter macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    ~/bunny/
    #9
    thats what I susspected the first time, but I am mounting explicitly as nfs (mount -t nfs -o rw x.x.x.x:/share /mnt/share) so its definately an nfs mount. If I mount it using the samba share then its rw party time (but my rsync stuff gets permission errors when running). The same rsync script is fine under the nfs share).

    its all very odd - perhaps its the version of nfs on the busybox box. THe solaris box mounts finewith rw in finder. this is bugging the hell out of me now :(

    Ive just added the nfs share via directory utility and once again no writeys with finder.... I think the Busybox knows I am playing with zfs to possibly replace/augment it and its jealous..

    :confused:
     
  10. foidulus macrumors 6502a

    Joined:
    Jan 15, 2007
    #10
    Thats what we were doing to, but the Finder is stupid and ignores what you say and scans the computer to determine what kind of protocols it supports, and for whatever reason sticks with SBM over NFS. The Apple guy recommended turning off bonjour, but that didn't work in our case. The only thing that worked was using the smb.conf to block the macs from even seeing the Samba.
     
  11. costabunny thread starter macrumors 68020

    costabunny

    Joined:
    May 15, 2008
    Location:
    ~/bunny/
    #11
    Ok Ive killed samba on the NAS and unmounted all shares and remounted - still no joy :(

    oooh this is silly
     
  12. foidulus macrumors 6502a

    Joined:
    Jan 15, 2007
    #12
    Have you tried bouncing the mac?
     
  13. belvdr macrumors 601

    Joined:
    Aug 15, 2005
    #13
    Check /etc/hosts.allow again. Is it a link? If so, are the link permissions _and_ the file permission it points to okay? The reason I ask, is that it logs /private/etc/hosts.allow and /etc/hosts.allow.
     
  14. mtie macrumors newbie

    Joined:
    Oct 26, 2009
    #14
    FS_READ_DATA error

    Did you ever resolve this problem. I'm seeing the same thing in 10.5.x. I'm also seeing some nfs issues when connecting to a redhat nfs server.
     
  15. frankonero macrumors newbie

    Joined:
    Nov 6, 2009
  16. cavocaldo macrumors newbie

    Joined:
    Jan 9, 2010
    #16
    This thread is very aged but...
    I had same problem with a Linuxbox satellite receiver, but after some attempt I found a workaround.
    Try to mount the nfs resource under /Network/Servers and write&read from finder seems to work.
     
  17. gosoon macrumors newbie

    Joined:
    Jan 21, 2010
    #17
    Possible solution

    I had this problem--it seemed to disappear when I added the options "nolocks,locallocks" to the mount. It seems that finder tries to do file locking in a way that terminal doesn't, which (possibly) explains why it fails. There's a post discussing it at:

    http://www.facebook.com/notes/james-gosling/nfs-on-snow-leopard/125738946623

    Fingers crossed that it keeps working...

    The slow read/write speeds can be fixed by increasing the rsize/wsize parameters in the mount options--64k for both seems to work well for me. (That's well-documented elsewhere.)
     

Share This Page