Unarchiver wont open .rar files

Discussion in 'Mac Apps and Mac App Store' started by Jowin, Sep 8, 2008.

Thread Status:
Not open for further replies.
  1. Jowin macrumors newbie

    Joined:
    Jun 2, 2008
    #1
    Hi,

    I've downloaded a massive 3gb application which is split into 73 .rar files, they're named "something.dmg.001" to "something.dmg.073". When i double click the first one it tells me that the application Unarchiver cannot open this file because its not a valid .rar archive. I've just used up half my monthly allowance on usenet downloading this thing so i could do with getting it to work really lol.

    I've tried renaming a few to end in .rar but they still dont open. - It could be that i have to rename all 73 to end in .rar but i tried opening a different .rar archive with Unarchiver, which was just one file, and it came up with the same message. macpar can do it but only with a .par file to start the process.

    Any ideas??? :confused:

    Cheers, for any help!

    owen
     
  2. wrldwzrd89 macrumors G5

    wrldwzrd89

    Joined:
    Jun 6, 2003
    Location:
    Solon, OH
    #2
    Those may not be RAR archives at all, if they have the dmg extension. Just for kicks, try opening the .001 file with Disk Utility.
     
  3. quovadis macrumors regular

    quovadis

    Joined:
    Oct 30, 2006
    Location:
    in PA
    #3
    May be you need this http://www.xs4all.nl/~loekjehe/Split&Concat/ before you unrar. I can confirm the software works on leopard
     
  4. Jowin thread starter macrumors newbie

    Joined:
    Jun 2, 2008
    #4
    no luck :(


    I need this application in order to do some work for a presentation at work on thursday too! arrgghhh :eek:
     
  5. Jowin thread starter macrumors newbie

    Joined:
    Jun 2, 2008
    #6
    ..ok so i tried unrarx and it wont open the files so they're not .rar files.

    I tried split&concat and it managed to make them into a dmg file but when you go to open it it says cant mount because of "illegal seek"???

    Whats that mean then? lol

    This is just teasing me now, making me think its worked until the last opportunity to say "nope, cant do that" :eek:
     
  6. Jowin thread starter macrumors newbie

    Joined:
    Jun 2, 2008
    #7
    ...tried using disk utility on the dmg file but said illegal seek when i tried to open it. opened it a different way and it came up in the side bar in disk utility, tried verifying and repairing but it did nothing:

    2008-09-08 21:53:53 +0100: Attach Image “iLife08.dmg”
    2008-09-08 21:53:54 +0100: Initializing…
    2008-09-08 21:53:54 +0100: Attaching…
    2008-09-08 21:53:54 +0100: Finishing…
    2008-09-08 21:53:54 +0100: Unable to attach “iLife08.dmg”. (Illegal seek)
    2008-09-08 21:53:54 +0100:
    **********
    2008-09-08 21:54:15 +0100: Disk Utility started.

    2008-09-08 21:54:24 +0100: [DUDiskController viewablePartitions] expecting DUDisk, but got nil
    2008-09-08 21:54:24 +0100:

    2008-09-08 21:54:27 +0100: [DUDiskController viewablePartitions] expecting DUDisk, but got nil
    2008-09-08 21:54:27 +0100:

    2008-09-08 21:54:52 +0100: [DUDiskController viewablePartitions] expecting DUDisk, but got nil
    2008-09-08 21:54:52 +0100:

    2008-09-08 21:54:54 +0100: [DUDiskController viewablePartitions] expecting DUDisk, but got nil
    2008-09-08 21:54:54 +0100:

    2008-09-08 21:55:30 +0100: [DUDiskController viewablePartitions] expecting DUDisk, but got nil
    2008-09-08 21:55:30 +0100:


    :(:confused:
     
  7. nexus144 macrumors member

    Joined:
    Jan 23, 2008
    #8
    Split and Concat should be able to open your file, I've never had any trouble with it. Try HJ Split instead, download the Java version as there is no specific mac version.

    I assume all the files are in the same folder and you are double clicking on only the .001 file and letting the program do the rest of the work.

    You could always try HL Split on Windows as a last resort.
     
  8. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #9
    This will take care of the problem- iLife

    I realize you are pretty new here, but you might want to review the forum rules you agreed to when you signed up- particularly about it not being acceptable to ask for assistance or methods to violate copyrights. Your last post pretty well confirms that is what is happening here.

    Seriously, if you need the iLife suite that much, just use overnight shipping. You will have a fully working version in less than 24 hours.
     
  9. smirk macrumors 6502a

    smirk

    Joined:
    Jul 18, 2002
    Location:
    Orange County, CA
    #10
    What you downloaded was a .dmg disk image file that was simply broken up into smaller chunks to facilitate the download. Those numbered segments need to be combined to form the original .dmg. You used Split & Concat but you also could have used the Terminal to do it:

    Code:
    cat ./something.dmg.0* > ./something.dmg
    At this point, you should have a very large .dmg file which should mount when double clicked. Since yours doesn't, it means you have a corrupt file. A .par2 or .sfv file should also have been included along with your 73 .dmg segments, and either of those can be used to verify that none of the 73 data files are corrupt.

    Did your download include anything besides the something.dmg.* files? If not, you're out of luck.

    Edit: Ah, just noticed the specific blatant illegal nature of the post. Yeah, seriously... you can't post stuff like that, man.
     
Thread Status:
Not open for further replies.

Share This Page