Unbearably slow 800mhz G4 iBook.

Discussion in 'PowerPC Macs' started by Jade Cambell, Dec 29, 2007.

  1. Jade Cambell macrumors 6502

    Sep 14, 2007

    I've got a G4 iBook here that is really really slow. It's running Mac OS 10.3.9, has an 800Mhz G4 CPU, and 1.12GB of ram (Built in 128mb + 1GB upgrade).

    Activity monitor shows over 800mb of ram free, and about 16000/0 page ins/outs.

    The CPU is also about 80% idle.

    Something is fishy. There is only 6GB of free hard drive space.. but I don't see how that could cause this nightmarishly slow performance. It takes 5 minutes to open a folder sometimes! Could it be bad ram? Malfunctioning hard drive? Does it sound like a hardware issue or software issue?

    I also noticed that there were a few folders in the hard drive such as "Previous Systems" "Rescued files" and "Damaged files." I already trashed "Damaged files" because it was just a bunch of random crap that no one would need and it was taking up space.

    Any ideas?

  2. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    I don't have a 10.3 install disc. Would upgrading it to 10.4 have the same effect?
  3. IMcD23 macrumors regular


    Aug 4, 2007
    Iowa, United States, Earth, Milky Way, . . .
    Yes, but not upgrading, erasing and installing, or archive and installing, if possible.
  4. Blue Velvet Moderator emeritus

    Jul 4, 2004
    Hang on... let's make an attempt to troubleshoot things properly before you go about reinstalling the OS. Clear some space from your harddrive by deleting all the previous system folders. OS X can need anything between 10 and 20gb free to run smoothly.

    Then check out your hard drive by running Disk Utility's diagnostic tools over it. See where you are then before taking further steps.

    Is it taking a very long time to start up?
  5. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    I'm currently verifying and repairing disk permissions. Not much showed up when I verified, but there was something about system/library.

    I have not restarted it yet. I just got it from the person who's paying me to fix it, and it was in sleep when they handed it to me. I suspected that they hadn't turned it off or restarted it in 4 years, but then the amount of free ram, and lack of page outs proved that idea wrong.

    Also, it doesn't let me verify the disk from within disk utility right now, so i'm gonna do that from my Tiger disk, once the repair disk permissions is complete.
  6. heatmiser macrumors 68020

    Dec 6, 2007
    Completely agree. I had Tiger running on an 800mhz G3 w/640mb on a 30 gig drive, and that well enough. If it's unbearably slow, it might be faster to just clean install than to try to root out every issue that's causing the slowdown.
  7. Blue Velvet Moderator emeritus

    Jul 4, 2004
    I doubt it's a permissions thing. Anything visible at root level on the harddrive outside System, Library, Applications and Users folders shouldn't be there. If it's valuable data, then back it up or move it temporarily into the Shared folder of the admin user. Anything else can be deleted.

    Sounds like a harddrive problem, sounds identical to problems I've experienced elsewhere with faulty drives... a telltale sign is how quickly it boots. Reinstalling OS X on a faulty drive isn't going to do much good.

    Regardless, the drive should be backed up.
  8. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    Well, i'll find out about the hard drive as soon as I boot it up on the tiger disk and run a disk utility test.

    Currently, the trash is being emptied from the "previous system" folder. It's only about 2.5GB though.
  9. tersono macrumors 68000


    Jan 18, 2005
    By far the best advice I've read in this thread - I completely agree.

    Delete old system folders. Delete caches. Ensure that your drive isn't suffering from errors. Take a very close look at any third party 'enhancements' or drivers that you've installed and uninstall anything not absolutely necessary (you can always re-install if it proves not to be the cause of the problem).

    If your disk shows as okay and everything else fails, THEN maybe consider archive/install, but take a look at all the other possibilities first.
  10. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    Well, it took about 3 minutes to start up. Pretty slow...

    It also hung on "Waiting for Printing Services" for about 30 seconds or more, right at the end of the blue bar filling up.

    I didn't let it finish emptying the trash cause it was taking too long, and it had frozen up. So i'm gonna finish doing that now, and then boot it up on the tiger disk and check the disk for problems.

    How do I delete caches? Which caches are you talking about?
  11. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    Riight. So now, I put in the tiger install disk, restarted the computer, held down C, and this is what happened.

    I got a screen with a very Mac OS 9 like interface, that let me select which startup disk I want to use. I selected the tiger disk, and pressed the forward arrow. The computer continued booting up, and has now gotten me to a black screen with a thick white curser at the top left corner. A root command/kernal/darwin screen. Whatever you wanna call it.

    Something is seriously weird here. Does anyone know why that might've happened? I can just reboot the computer, but I want to run a disk test on the hard drive!

    edit: The computer is running faster now. It booted up in about a minute, and opens folders faster, ever since freeing up that 2.5GB of space. There's now nearly 9GB free on the hard drive. But it's still way slower than it should be...

    edit: ****... I don't know what happened. I was on the desktop, I opened up photoshop, I closed photoshop. I restarted the computer, and it couldn't find the hard drive!!!!!?!?!?!?!?!

    edit 3: Well, it couldn't find the system folder. The hard drive is intact.. kind of. I managed to boot up on the tiger disk and get into disk utility. The hard drive does need repair and disk utility is working on that right now, but i'm worried that I somehow deleted the system folder from the computer, even though I clearly didn't. I might have to just install tiger...

    edit 4: Disk utility tried to rebuild the catalog B-tree, but then said that the hard drive couldn't be repaired. Now "Macintosh HD" turned grey on the left of the disk utility window, and the info down below no longer displays information such as "file count", "free space".. etc.
  12. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    Alright, I think the hard drive died. It doesn't show up in disk utility anymore. I have to tell this person that all their data is gone. What if they think it's my fault? yikes..

    Anyways.. is there any other conceivable way that I could save the data off this hard drive? I tried firewire target disk mode, and the ibooks screen just remained black and nothing happened. Now, the hard drive doesn't show up in disk utility, and I get a flashing question mark when I try to boot up without a disk in it.

    However, sometimes, I get the apple and the spinning wheel below it, like normal, but it just stays there forever.
  13. rhyndu macrumors regular

    Dec 17, 2007
    A Planet Orbiting Sol!
    It is your fault. You didn't back it up when people said you should. Instead you messed with it.

    Anyway, if the Apple spin screen EVER shows up, it is a sign that the disk isn't *completely* dead yet. Keep on trying to boot up TD mode, but anything other than that will put too much strain on the disk. You could also google "pro disk failure recovery software mac" :D
  14. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    I "messed" with it?

    I have performed Disk Utility verify and repair on dozens of macs, possibly hundreds. If the computer wasn't ****ed up, that wouldn't kill it.
  15. ktbubster macrumors 6502a


    Jan 20, 2007
    The person gave it to him to fix. Honestly, if anything the person who gave it to him, if they had anything important on the drive should have backed it up! If they didn't, it's their fault. They KNEW the computer was having problems and gave it to someone to fix. Honestly, if they hadn't backed up anything they had on that drive before hand then they were just stupid. You send your computer to someone or give it to someone to be fixed, then YOU should have enough sense to back it up.

    Yes, people told him to back up before all this, but in all fairness, the owner of the computer would be just as much at fault if not more for that loss of data.

    Just my 2 cents.

    Either way, yeah... looks like it's time for a new drive. However, on the plus side, old ibook hardrives of 40 or 60gb can be had for pretty low prices around here. :)
  16. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    Hey! Target disk mode just worked! It shows up in Disk Utility on my computer as "27.9 GB AAPL FireWire Target Mode" or something. But I can't access any data, and no hard drive icon appears on the desktop or in the sidebar.

    edit: *sigh*.. whatever. It's dead.

    It was given to me to fix. Not by a friend. By a client. I do this professionally, and i've never had something die on me before. But if I were the client, I would backup all my stuff the minute I see that my computers being fishy. Then, when I give it to the fixer, he could do whatever he wants (i.e. wipe the drive to fix it before it's too late).

    Apple tech guys should not be responsible for people's data. That's the peoples problem. The Apple tech guy is responsible for fixing stuff. And if I wasn't worried about walking on this clients data, like walking on eggs, I would've been a lot more quick and ruthless in my attempts to fix it. The hard drive died. I didn't kill it. How could I have? Seriously... running disk utility and trashing a previous system folder does not kill hard drives.

    Well, thanks for the help guys!
  17. sushi Moderator emeritus


    Jul 19, 2002
    FWIW, when a hard drive is close to dying -- as in physically dying -- doing disk utility type functions can cause it to fail.

    At this point in time, I would suggest that you stop using the computer and let it cool down. Remove all sources of power, then cycle the power button. Wait a few hours. Overnight if you have time. Then try starting in target mode and back up everything first.

    BTW, this technique has worked for me a few times. In most cases I was able to get most if not all of my data off of the HDs before they completely failed. YMMV.

    Regardless of whether or not the owner backed things up, when you troubleshoot a computer it is always best to assume that they did not.

    When I troubleshoot, the first question that I ask them is if their data is backed up. I usually mention music, pictures, videos, documents, URLs, etc. to get them to really think about what I am asking. And usually the answer is no or partially backed up. So the first thing that I do is create a backup for them. Sometimes I do it right there or at my place -- depends on the situation.

    The really bad cases are when they look at you and sheepishly smile and say that they meant to do a backup but never got around to doing it. And that all of their memories in pictures and important documents are on the HD and could I please save them. These situations can get interesting depending on what you find when you begin trouble shooting.

    Anyhow, some good lessons learned in this thread.

    Edit: To the OP, it took me a while to write the response above. Slow typer. By the time I posted this, you had written the post above which I did not see. You still might want to leave it off for a while and see if you can see it under target mode. Sometimes removing all power sources and letting things cool down, can give you a few minutes of working time if some data needs to be recovered. Of course if there is critical data on the HD, then professional data recovery may be the way to go. If data does not need to be recovered, then please disregard these comments.
  18. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    Thanks. After sitting untouched for several hours, I tried target mode again and in Disk Utility, I actually got a greyed out "Macintosh HD" underneath the hard drive of the iBook. But I didn't realize it was there until after I unplugged it thinking it wasn't working again.

    I think the partition "Macintosh HD" is simply unmounted, and I need to mount it to access the data. But to do that, I need to get that Macintosh HD to show up in disk utility again...

    I tried target disk mode with the laptop upside down, on it's side.. etc, trying to find a way in which it would work. To no avail.
  19. rhyndu macrumors regular

    Dec 17, 2007
    A Planet Orbiting Sol!
    So you still get a black screen when you hold [:apple:][T]?
  20. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    No. I get the firewire symbol bouncing around the screen now, but it freezes within a minute. Meaning, the symbol stops bouncing.

    The "27.9GB" hard drive shows up in Disk Utility on my computer, but no "Macintosh HD" partition below it like there should be. Except for the one time where a greyed out "macintosh hd" showed up below it. Then I foolishly unplugged the firewire cable since I didn't realize it had shown up like that. But it was likely to freeze within a couple seconds anyway.

    I'll try it again tomorrow morning.
  21. rhyndu macrumors regular

    Dec 17, 2007
    A Planet Orbiting Sol!
    Some Friendly Advice

    I'd say, at this point, you should contact the customer, tell him/her his drive died, ask if he had any backups, and that he needs a new hard-drive. If he does have backups, tell him that you need them to restore the data to his computer and ask for the 10.3 install disk (Software Recovery, grey cd) so you can fix his computer.

    If he doesn't have a backup, ask how valuable his data is. He can spend ~400 USD on getting his drive data recovered by experts (Google "drive recovery"). Otherwise, all his data is lost. Ask for the 10.3 install disk then, too.

    Before this happens, STOP cycling through ON/OFF. Don't turn it on at all. Any more power cycles may break the drive even more.

    In either situation, buy a HD and install it in the machine (or get someone else to do so if you don't know how.)

    And apologize to the customer, even though it wasn't your fault.
  22. Jade Cambell thread starter macrumors 6502

    Sep 14, 2007
    Well, this morning, nothing seemed to be different about trying target disk mode, but suddenly "Macintosh HD" showed up on my desktop, after numerous failed attempts very similar to last night.

    However, when i'd try to transfer something, the ibook would freeze up. However, after setting the ibook down at an odd angle, i've managed to keep it running for extended periods of time. I've already transferred nearly 15GB of stuff.

    The iBook is sitting on a chair with the back of the screen (where the apple logo is) facing down, and the computer part sticking straight up into the air. That's what sort of made it work. :D
  23. sushi Moderator emeritus


    Jul 19, 2002
    Good to hear that you are having some success.
  24. iBunny macrumors 65816

    Apr 15, 2004
    Its slow because its a G4 800MHz...

    Soultion: Buy a new computer.

Share This Page