Unbinding Dead Active Directory from Directory Access

Discussion in 'macOS' started by kamikaze kyle, Jun 8, 2006.

  1. kamikaze kyle macrumors newbie

    Jun 8, 2006
    I recently had to gut the Active Directory and Domain on my Windows 2003 server, and change over to a new domain name. I forgot to unbind my Powerbook beforehand, and trying to unbind it through the Directory Access panel refuses any account name or password I throw at it (therefore it won't unbind).

    Because of this, my shares have ceased functioning. I can't connect via a standard SMB connect using the NetBIOS name or IP address (I keep getting Permission Denied). I've already disabled the security options, and my account does have appropriate access. I've also tried a manual connect via the console (# mount_smbfs -W myworkgroup //username@netbiosname/share ./myshare)

    Anyway, if I can manually update my domain name (or unbind it), the share problem should fix itself. I've added in my new domain to the prefered domain box, and added the in the new domain in the "Allow Administration by:" box as well.

    I've been searching for days, but haven't found anything. Anyone have any ideas?
  2. kamikaze kyle thread starter macrumors newbie

    Jun 8, 2006
    Erm...OK I just fixed one problem, somehow. I went ahead and added a fully qualified domain name to the "Allow administration by:" box leading directly to my Domain Admins group and server. I then randomly attempted a SMB connect to my shares via workgroup and it worked.

    Scratching my head on that one, but I'm still looking for a way to unbind the active directory domain from the Directory Access panel.

    I'm almost afraid to restart and risk not being able to connect again :D

Share This Page