Uncompatible apps on 1st gen

Discussion in 'iPod touch' started by Importroller, Nov 13, 2009.

  1. Importroller macrumors newbie

    Joined:
    Aug 7, 2008
    #1
    I have a 32GB 1st gen IPT. it is jailbroken with 2.1. I have been having problems downloading certain apps from the App store saying it is not compatible with my Ipod. I thought maybe I have to be 3.0 or higher, but before i try to upgrade to 3.0 or anything higher, i wanted to know if this will fix the problem, or should I try something else
     
  2. na1577 macrumors 6502a

    Joined:
    Jan 20, 2008
    #2
    It could be two things:

    1) The app requires a feature that isn't available in your current firmware (Such as In-App-Purchases, which require 3.0)
    2) The app requires a hardware component that isn't built into your iPod, like a microphone.

    The first can remedied by updating your software, the second obviously cannot.
     

Share This Page