Unexpected error 0xE8000001

Discussion in 'iOS Programming' started by Fremen93, Oct 6, 2008.

  1. Fremen93 macrumors newbie

    Joined:
    Aug 25, 2008
    #1
    I am currently getting this error whenever I connect my iphone to the USB port on my macbook pro.

    "Your mobile device has encountered an unexpected error (0xE8000001)"

    I have searched the forums but it appears that people only see it when first setting up their device. I had my device working fine last week, I was testing apps on it and running it in debug mode all day on friday. I did nothing to it this weekend and now suddenly when I plug it in, it gives me this error message. I think Apple is causing too many problems with the rather insane certificates and provisions and all this nonsense we have to have just to copy a program over to an iphone. I have a feeling developing apps for the Google OS is not going to be such a problem, and once more phones come out with it, I think Apple may have to relax some of these DRM-like restrictions.
     
  2. PhoneyDeveloper macrumors 68030

    PhoneyDeveloper

    Joined:
    Sep 2, 2008
    #2
    Try to reboot the device. Hold down the powerbutton and the home button at the same time. When it says 'Slide to Power off' do it. Then restart. This has fixed this error for me.

    If that doesn't fix it then try to restore the device. That has always fixed this error for me.
     
  3. robotspacer macrumors member

    Joined:
    Jun 25, 2007
    #3
    If restarting your device doesn't help, try restarting your computer before you go through the trouble of a restore. That fixed it on a couple occasions for me.
     
  4. fenrus110 macrumors regular

    Joined:
    Mar 24, 2008
    #4
    make sure the settings Build properties are correct for BOTH the "Project Info" (double click your project) and the "Targets".

    Expand Targets and double click the icon below it.

    Restart XCode too, after apply provisioning profiles.
     
  5. Agnuspathos macrumors newbie

    Joined:
    Dec 30, 2008
    #5
    iPod error 0xE8000001 - Solved!

    After reading several posts and trying a lot of procedures a friend came out with this one and it worked!

    Disconnect the iPod from the computer and then create a new user account in System Preferences.
    After that, Log Out of the main account and Log In with the new user account.
    Connect your iPod to the computer, wait for iTunes to launch or launch it yourself if it doesn't.
    If it works, i. e., if the iPod is recognized, go to new user's Library and copy the Lockdown folder to Users > Shared.
    Then Log Out from new user account and Log In again with main user account.
    Go to the main user's Library and place in it the Lockdown folder copied (Users>Shared). If it asks to replace say yes.
    Restart your computer and Log In with main user account.
    Reconnect the iPod!

    It worked with a MacBook Pro running 10.5.6.
     
  6. reetu.raj macrumors newbie

    Joined:
    Mar 12, 2009
    #6
    Thank you PhoneyDeveloper !!
    It solved my problem :D
    thank you so much again :D
     

Share This Page