Unexpected Error - Redsn0w 4.3.2 iPhone 3GS Jailbreak

Discussion in 'Jailbreaks and iOS Hacks' started by Danielg8, Apr 22, 2011.

  1. Danielg8 macrumors newbie

    Joined:
    Apr 22, 2011
    #1
    I jailbroke my iPhone 3GS for the 1st time with Redsn0w for 4.3.1. That went perfectly fine, but then just yesterday I attemted to upgrade to 4.3.2 and then jailbreak again. I followed the directions exactly and the 1st time I went through the process right as I was following the steps to put it into DFU mode, the phone screen went white, and a message came up on the Redsn0w screen saying "and unexpected error occured. Please reboot and try again from another USB port."

    I tried this several times from all of my USB ports on my MBP. Everytime, the same thing. I opened iTunes again after a while & iTunes showed my regular phone docked AND a 2nd 'iPhone' which it stated was in Recovery mode & needed to be restored.

    Someone else suggested that they tried with another computer (a PC) and were able to make it work. I tried that with a PC running Windows Vista (ugh), and everything on the Redsn0w screen makes it look like it worked, but the phone never actually was jailbroken (i.e. no Cydia & no DFU mode, etc).


    HELP!! :confused:

    Does anyone have an idea of what could be causing this & what I can try? I'm frustrated & exhausted :(
     
  2. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #2
    Try restoring the 3GS to official 4.3.2 and then try the redsnow JB again.
     
  3. Danielg8 thread starter macrumors newbie

    Joined:
    Apr 22, 2011
    #3
    I actually ended up restoring from a back-up and am now running officially 4.3.2, I tried again to JB, but it gave me the same problem. :-/
     
  4. amemoryoncelost, Apr 23, 2011
    Last edited: Apr 23, 2011

    amemoryoncelost macrumors 6502

    Joined:
    Jun 14, 2004
    #4
    I've been having this issue for the past hour or so. Restoring for the second time currently and hoping all goes well. The first time or two I was trying to put the phone into DFU mode and I guess I messed up because it gave an error. So I started all over and now it won't even go through the DFU steps, it just says I need to try again.

    I'm starting from scratch on this phone, not restoring from a backup...

    EDIT: This has got to be about the most annoying thing EVER!!! Phone is about to fly out the window.
     
  5. amemoryoncelost macrumors 6502

    Joined:
    Jun 14, 2004
    #5
    Okay, I tried multiple times on this computer, my girlfriends macbook and then to my hacked netbook which is dual booted. After failing on the netbook, I realized I didn't have iTunes installed. Installed that and second try I was jailbroken. So if you can, find a windows machine and do it that way. Looks like this has been an issue with the last several redsn0w releases...
     
  6. Ramsteiner macrumors member

    Joined:
    Sep 3, 2007
    #6
    Anyone figure this out yet? I have the same issue on a brand new Iphone 4.
     
  7. Danielg8 thread starter macrumors newbie

    Joined:
    Apr 22, 2011
    #7
    I tried a few times on a laptop running Windows Vista. The steps seemed to look like they were working on the computer screen, but my phone never went through the whole process and it never went into DFU mode. So in other words, the computer screen was showing what was going on step-by-step, but nothing was happening on the phone.

    Some people on another forum posted about trying on Windows 7 and "running Redsn0w" as an administrator under XP..? I don't have any access to any machines running Windows 7 so I have no idea what to do at this point. :confused:
     
  8. Danielg8 thread starter macrumors newbie

    Joined:
    Apr 22, 2011
    #8
    That's interesting that it's happening to you with a 4. From everything I've found, it seemed like only 3G/3GS models were being affected.
     
  9. Danielg8, Apr 25, 2011
    Last edited: Apr 25, 2011

    Danielg8 thread starter macrumors newbie

    Joined:
    Apr 22, 2011
    #9
    What is the difference (if any) between Redsn0w & PwnageTool? I just saw on http://blog.iphone-dev.org/ that PwnageTool 4.3.2 is available.

    What are the pros & cons of using one over the other? The first time I ever jailbroke was 4.3.1 using Redsn0w, so I'm not familiar with a lot of this stuff...
     
  10. jmp473 macrumors newbie

    jmp473

    Joined:
    Apr 25, 2011
    Location:
    Atlanta
    #10
    The unexpected error and related issues plagued me for over a week!!!! Guess i went through the jailbreak/DFU/fix-boot etc. process more than a hundred times trying everything i could think of including installing XP through virtualbox (bootcamp doesn't work on my mac). Yesterday i saw this: http://news.metaparadigma.de/iphone-issues-with-iphone-dfu-mode-in-macos-1056-1695/ and resorted to swapping out some system files with Tiger (didn't have 10.5) no effect, Mac Mini restarted OK but this morning my system was broken so i reinstalled Snow Leopard 10.6.3 tried again and redSn0w (0.9.6rc14) worked!!!


    Latest PwnageTool doesn't upgrade the baseband
    PwnageTool 4.1.3 unlock edition only works with (upgrades baseband of) ipsw 4.2 (although there was a fix for ipsw 4.1 it didn't work for me)

    save your blobs and best of luck!
     
  11. Ramsteiner macrumors member

    Joined:
    Sep 3, 2007
    #11
    Finally figured this out on my new Iphone 4. Initially I had the same situation/error as in post #1. Then I tried Pawnage tool which failed in error code 1601. Both relate to USB issues (never had one on my 2007 Imac before). I then replaced my current Iphone USB cable (using the one that came with my Iphone 2G) with the new one right out of the Iphone 4 box. I tried Redsnow again and three minutes later had a JB Iphone 4. BTW the Iphone 4 syncs just fine with the old USB cable in fact everything works perfectly with the old cable, just wouldn't work on the JB.

    Hope that helps someone else out there.
     
  12. MaxBurn macrumors 65816

    MaxBurn

    Joined:
    Nov 25, 2010
    #12
    Several tips about redsnow on windows, needs to be set up to run as xp sp3, do the run as administrator also. From there when you put it in dfu mode it doesnt wait long enough for the phone to reboot and the computer to see it. If you know the phone os in dfu mode wait till the computer sees it via the usb connect notifications then go back a step on redsn0w and foreward again and it will pick it up.

    I think I have had this issue with reds ow in the past too, wish they would put some notes in the readme file or something.
     

Share This Page