Unexpected results from rsync

Discussion in 'Mac Apps and Mac App Store' started by UncaMikey, Aug 12, 2016.

Tags:
  1. UncaMikey macrumors newbie

    UncaMikey

    Joined:
    Jul 5, 2016
    #1
    I've asked this question on other forums, hoping for some guidance.

    I have an iMac running 10.11.6 and have updated rsync to 3.1.2 (using homebrew). I am trying to use rsync to back up from my iMac to an attached USB hard drive or thumb drive using this command:

    rsync -vaE --progress --delete /source/files/ /destination/files/

    My goal is to have the destination be an exact copy of the source.

    My problem: I use Finder to originally copy /source/files/ to /destination/files/. Using Get Info, I see the size and number of items in source and destination are exact matches. Then I run the rsync command above to verify destination is an exact match to source, but it rewrites many files (some hidden, some not) before completing successfully. But if I do another Get Info on source and destination the size and number of items no longer match.

    A further oddity: if I run rsync twice in a row, the second run still finds files to write/rewrite. Why is this? Shouldn't the first run have exactly synchronized the destination to the source?

    I should also add that I do the rsync on several large groups of files (music files, images, documents) and sometimes rsync runs quickly and as expected. The odd results described above do not happen every time. I have also tried dropping the -E option (is it still required?) but it doesn't seem to matter.

    Shouldn't destination be an exact copy of source after rsync, with the same size and number of items, etc? Shouldn't rsync exactly match destination to source, incl resource forks, .DS_store, hidden files, etc.? TIA for any help and insight.
     
  2. Negritude macrumors 6502

    Joined:
    Jul 14, 2011
  3. UncaMikey thread starter macrumors newbie

    UncaMikey

    Joined:
    Jul 5, 2016
    #3
    This is not the answer I was looking for, but it is the best answer to my question of how to use rsync to backup up folders/files. After a lot of research and testing, I finally gave up on doing rsync, it is beyond my limited capabilities and I could not get it to do what I wanted. Fortunately, I found a very good, cheap GUI to rsync in the App Store: SyncBuddy. Very easy to use, very accurate, and yes, it is rsync, as shown in Activity Monitor.
     

Share This Page