Unibody 15" MacBook Pro Graphics Woes

Discussion in 'MacBook Pro' started by Cathode, May 4, 2009.

  1. Cathode macrumors regular

    Cathode

    Joined:
    Aug 5, 2008
    Location:
    Flagstaff, AZ
    #1
    Hello:

    A friend of mine just got me into World of Warcraft. I seem to be able to play at a good framerate on moderate settings. It is sluggish when using the 9400 and pretty fluid when using the 9600M. However, the 9600M seems to be giving me one hell of a time. Randomly the computer screen will die (black, no backlight or image). It will appear to stop responding to all commands and I have to do a hard reset. When I reboot I'm giving a "OS X has failed" error. I have an option to report the error (which I have) and I'm given a bunch of stuff to send to apple.

    I will post the error in it's entirety below. I just am wondering if I should take this in for repair or will they not cover it because it only is happening on a game? I haven't played any other games yet and the only other graphics demanding application I use is Aperture which hasn't really acted up at all.

    I've also noticed that I ALWAYS have to enable the 9600M manually. No matter what, my computer always boots to the 9400. Doesn't matter if I'm connected to a power source or not. If I boot from fresh it will default to the 9400. Is this normal? Even if I've previously selected the 9600M and restart? This is frustrating as I have to restart [after a crash], then select the 9600M which logs you out and back in again. It just seems like unnecessary wasted time.

    Here is the error report:

    Mon May 4 10:13:27 2009
    panic(cpu 0 caller 0x00405DEB): "NVRM: Read Error: GPU 0, PCI 0x00000200, BAR0 0xa4000000 0x3f8a0000"@/SourceCache/xnu/xnu-1228.9.59/iokit/Kernel/IOLib.cpp:724
    Backtrace (CPU 0), Frame : Return Address (4 potential args on stack)
    0x2fe9fc38 : 0x12b4f3 (0x45b13c 0x2fe9fc6c 0x1335e4 0x0)
    0x2fe9fc88 : 0x405deb (0x49da40 0xe1b280 0x2fe9fccc 0x2fe9fcbc)
    0x2fe9fca8 : 0xbec4f7 (0xe1b280 0xe1b280 0xddfc88 0x0)
    0x2fe9fce8 : 0xea3d1a (0x50da404 0x4d86804 0x61002c 0xc28b13)
    0x2fe9fd28 : 0xeb779a (0x4d86804 0x61002c 0x2fe9fd68 0xc289af)
    0x2fe9fd48 : 0xd1e881 (0x4d86804 0x50ae804 0x2fe9fe58 0x4fd1004)
    0x2fe9fd68 : 0xd5105d (0x4d86804 0x50ae804 0x1 0x0)
    0x2fe9fec8 : 0xcd017e (0x4d86804 0x0 0x2fe9ff18 0x2fe9ff14)
    0x2fe9ff38 : 0xbed0a5 (0x50da404 0x203fe004 0x0 0x0)
    0x2fe9ff58 : 0xbd81f0 (0x203fe004 0x0 0x10 0x0)
    0x2fe9ff78 : 0x13eed2 (0x4998400 0x203fe004 0x1a336f 0x4450d60)
    0x2fe9ffc8 : 0x1a017c (0x0 0x0 0x1a30b5 0x724f3c8)
    Backtrace terminated-invalid frame pointer 0
    Kernel loadable modules in backtrace (with dependencies):
    com.apple.nvidia.nv50hal(5.3.6)@0xe30000->0x1084fff
    dependency: com.apple.NVDAResman(5.3.6)@0xbd3000
    com.apple.NVDAResman(5.3.6)@0xbd3000->0xe2ffff
    dependency: com.apple.iokit.IONDRVSupport(1.7.1)@0xbc5000
    dependency: com.apple.iokit.IOPCIFamily(2.5)@0x637000
    dependency: com.apple.iokit.IOGraphicsFamily(1.7.1)@0x785000

    BSD process name corresponding to current thread: kernel_task

    Mac OS version:
    9G55

    Kernel version:
    Darwin Kernel Version 9.6.0: Mon Nov 24 17:37:00 PST 2008; root:xnu-1228.9.59~1/RELEASE_I386
    System model name: MacBookPro5,1 (Mac-F42D86C8)
     
  2. iLog.Genius macrumors 601

    iLog.Genius

    Joined:
    Feb 24, 2009
    Location:
    Toronto, Ontario
    #2
    Have you tried to adjust or lower the settings? I too run WoW on OS X with mid to high settings and never had a crash once with the 9600M GT. I don't think you can call it a hardware failure unless you've seen other failures in other applications or in OS X.
     
  3. ibd macrumors member

    Joined:
    Apr 12, 2008
    #3
    I think it might be a hardware defect. Have you tried other games yet, maybe under Windows, too?
     

Share This Page