Unibody Drops WiFi and/or Internet Connection

Discussion in 'MacBook' started by WayOutWest, Apr 26, 2009.

  1. WayOutWest macrumors newbie

    Joined:
    Oct 30, 2008
    Location:
    Lexington, KY
    #1
    So my 6 month old Unibody has had an issue for a while that it drops the internet connection, though keeping the network/WiFi connection. It started out just on campus where there is a campus wide SSID that is unencrypted, though requires a login to start browsing. A restart of the computer fixes this issue, though it always repeats itself (usually after 30-45 minutes of browsing, no downloading). Lately, the issue has been getting worse. It is now dropping the connection on other APs, and even stops the Airport card altogether (KisMac can't even scan). I had a backlight bleeding issue fixed by Apple. Is this connected? I know the airport card is in the screen, so maybe they didn't fix it well.

    thanks in advance and let me know if you need anymore information.

    sam
     
  2. rd261 macrumors regular

    Joined:
    Sep 24, 2007
    #2
    I had a similar issue with my black macbook when I bought it. Apple looked at it but they couldn't find anything wrong with it since the problem was intermittent and it dint happen at the genius bar. I complained to the manager and since it was under the 14 days return period they just gave me a new one. You should take it to the genius bar and hope for the best.
     
  3. chrislaw macrumors 6502a

    chrislaw

    Joined:
    Apr 11, 2009
    Location:
    central ohio
    #3
    i got mine about a month ago and mine does it all the time at home.

    Also it says over and over that my password on my home network is wrong... even though it isn't..

    so i have to type it in over and over again... and eventually it works..

    well until the next time i restart anyway.
     

Share This Page