unibody hd swap with blackbook hd

Discussion in 'Mac Basics and Help' started by kieran13, Jun 14, 2009.

  1. kieran13 macrumors newbie

    Joined:
    Jun 14, 2009
    #1
    Ok so i had a black book and a unibody macbook and i needed to switch the hard drives long story so i asked the mac tech at my work and he said if i updated both to 10.5.7 then just switched the hd's i would be fine. well i did that and now the blackbook with the new hd fine but when i boot the unibody it goes to a black screen and data scrolls down the screen for like 15 seconds like its confirming every action its doing then it boots and runs fine how do i fix this issue
     
  2. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #2
    Open Terminal and type:

    Code:
    sudo nvram boot-args=""
     
  3. kieran13 thread starter macrumors newbie

    Joined:
    Jun 14, 2009
    #3
    should i back up my data first on a external hd?
     
  4. r.j.s Moderator emeritus

    r.j.s

    Joined:
    Mar 7, 2007
    Location:
    Texas
    #4
    In general, yes. Before running this command, I don't believe it to be necessary.
     
  5. kieran13 thread starter macrumors newbie

    Joined:
    Jun 14, 2009
    #5
    after i put it in terminal it asked for my passwork and when i type it in nothing comes up like i cant see the passwords not evan stars
     
  6. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #6
    Terminal and single-user mode never display the password as it's being entered in. Rather than going the Terminal route, you can do the same reset by following this. Your computer seems to be booting into verbose mode.
     

Share This Page