Unibody Macbook pro "screen flicker" while scrolling?

Discussion in 'MacBook Pro' started by P90Xfit, Feb 15, 2009.

  1. P90Xfit macrumors regular

    Joined:
    Feb 7, 2009
    #1
    I read about the screen flicking problem. The thing is my UBMBP flickers while I'm scrolling. Like in the Application window when I'm scrolling down and it flickers, this normal?
     
  2. P90Xfit thread starter macrumors regular

    Joined:
    Feb 7, 2009
    #2
    OK, I switched to the 9600M, then back again. Seems to have fixed it.

    Is the 9400M GT broken or something? Is this wide spread problem fixed through hardware or software?
     
  3. P90Xfit thread starter macrumors regular

    Joined:
    Feb 7, 2009
    #3
    OK it is doing it again. So I am going to make the long drive to the Apple store.

    Any one know if its the Graphics card, or power inverter, or... what?
     
  4. Roy Hobbs macrumors 68000

    Roy Hobbs

    Joined:
    Apr 29, 2005
    #4
    I believe its a known issue with the graphics cards
     
  5. lordthistle macrumors 6502

    Joined:
    Feb 29, 2008
    Location:
    Italy
    #5
    Should be the graphics drivers. They are not that good.
     
  6. P90Xfit thread starter macrumors regular

    Joined:
    Feb 7, 2009
    #6


    know how to go about changing the driver for the 9400?:confused:

    that would be great.
     
  7. lordthistle macrumors 6502

    Joined:
    Feb 29, 2008
    Location:
    Italy
    #7
    You can't. But good drivers will come out eventually (I hope).
     
  8. P90Xfit thread starter macrumors regular

    Joined:
    Feb 7, 2009
    #8
    So I Called Apple

    I called them and they had me do an Archived reinstall, looks good so far. I'll post back later. I hope this is a permanent solution to my little problem.
     
  9. hamidb83 macrumors newbie

    Joined:
    Dec 14, 2008
    #9
    The same problem here with 8600

    I have the same sort of problem with my older MBP which has 8600 card. I guess the 8600 drivers should be stable by now. It happened since I installed Safari 4.0b. Safari itself works awful when you scroll.
     
  10. P90Xfit thread starter macrumors regular

    Joined:
    Feb 7, 2009
    #10
    No it was system wide. I got apple to send me another one. Since this was a major inconvenience to have to switch out my notebook yet again, they upgraded me to the 2.53Ghz, 4G RAM, 320GB HD 7,200. for $225.00 more I got it today, and it seems to be running fine. Although I'm not thrilled with the screen calibration.
     

Share This Page