Unibody MB + Special Keys + Spaces?

Discussion in 'MacBook' started by BrownManUPS, May 15, 2009.

  1. BrownManUPS macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #1
    Hi all.

    I just upgraded to a unibody macbook (I know, WWDC...but there were some special circumstances that allowed me to get this for a better bargain...). There are the special keys already mapped onto the Fn keys as I can see, but I really am missing my "F8 = spaces" funciton. I know that you can go into System Prefs -> Keyboard and turn off the Special keys, but I kind of like the mappings and the pictures going with them (very anal).

    So, can we either a) remap all the keys without using special keys (which then allows me to map F5 or F6 to spaces) or b) use F5 or F6 as spaces with special keys turned on? If we do (a), I'm gonna need to know how to get volume control and iTunes control working!

    Thanks!
     
  2. amabo macrumors member

    Joined:
    May 2, 2009
    #2
    If you hold the fn key at the bottom left hand corner of your keyboard, that will allow you to bypass the preassigned function keys such as Play/Pause, Dashboard, Expose, etc. If you want to set F5 to be Spaces then do the following.

    System Preferences -> Expose and Spaces -> (near the bottom) To Activate Spaces -> F5

    If you want it to be F4 with the special keys or whatever you were describing earlier, just make sure to hold down the fn key while you press F4.

    Hope that helps.

    EDIT: PS - I also go to IU :D @mattsa on Twitter
     
  3. upaymeifixit macrumors 6502a

    upaymeifixit

    Joined:
    Feb 13, 2009
    #3
    We will do "B"

    I wish there were just one more key for spaces, because I am using the F5 and F6 keys for brightness.
    You do not need to re-map the keys, that is way to extreme. All you need to do is assign F5 or F6 keys to spaces. Do this by going to:
    System Preferences/Expose & Spaces/Spaces/To activate Spaces: And from the pulldown menu select your key.

    The reason this works, if I can remember correctly, is because the F5 and F6 keys are not set as special keys unless you have a backlit keyboard. They are the only keys that act as standard function keys all the time.
     
  4. BrownManUPS thread starter macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
    #5
    Just pressing F5 with this method still doesn't let it work, but as the person above suggested, pressing fn+F5 allows it to work. Unfortunately I just want to press F5....
     
  5. Zazoh macrumors 6502a

    Zazoh

    Joined:
    Jan 4, 2009
    Location:
    Mico, Texas
  6. BrownManUPS thread starter macrumors 6502a

    BrownManUPS

    Joined:
    Jul 30, 2007
    Location:
    California
  7. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #8
    Go to System Preferences—>Keyboard & Mouse—>Keyboard:

    Then check the box that says "Use all F1, F2, etc. keys are standard function keys"

    Now F8 should be Spaces, F9 should be Exposé, F10 should all windows in current app, F11 is show desktop, and F12 is dashboard.
     

Share This Page