Unibody MBP Sleep Issue

Discussion in 'MacBook Pro' started by macjunkie33, Jan 22, 2009.

  1. macjunkie33 macrumors member

    Joined:
    Jan 8, 2009
    Location:
    OH
    #1
    Ive only had my 15" MBP for a week so ive been getting used to the new machine. I was wondering why when I close my lid to put it to sleep and then pick it up and put it in my bag, it wakes up and the apple logo glows? I hear the disks spinning up whenever i move the machine, is there a reason for this?

    This can't be helpful for preserving battery life while the computer is sleeping, as a 15 minute trip to work this morning left me with 94% battery life. is this just a leopard flaw or something to take to the apple store?
     
  2. leodavinci0 macrumors 6502

    Joined:
    Jan 26, 2006
    #2
    My brother had this issue with his new MBP. You didn't buy an express card for it for any reason? In my brother's case it seems his Kensington media card reader caused the MBP to wake even with the lid closed. I had this issue with my old PB too. I eventually found out it was from a fax app I installed. So, did you add any apps recently or express cards? Or has it done this from day one? I also had an issue with a certain bluetooth device waking my computer. Do you use any BT peripherals with your computer? If so try turning off the "Bluetooth device will wake computer" option under System Preferences / Bluetooth.
     
  3. macjunkie33 thread starter macrumors member

    Joined:
    Jan 8, 2009
    Location:
    OH
    #3
    I was using a Kensington bluetooth mouse so when I turned off bluetooth it now stays asleep. Thanks for the suggestion! Whew! glad that was an easy fix...
     
  4. leodavinci0 macrumors 6502

    Joined:
    Jan 26, 2006
    #4
    Glad I helped. Why am I not surprised it was kensington again, I've had bad RAM by them as well as the express card I got my brother for christmas.
     
  5. Niiro13 macrumors 68000

    Joined:
    Feb 12, 2008
    Location:
    Illinois
    #5
    It's the same for all bluetooth devices, not just Kensington.

    You can turn it off in settings "Allow bluetooth devices to wake this computer" is turned on by default.
     
  6. ReplayMan macrumors newbie

    Joined:
    Jan 25, 2008
    #6
    I'm glad I came across this thread. You saved me a trip to Apple.

    I returned from from lunch and noticed my MBPro was very hot. With the lid closed...I can see the screen cycling on and off. I searched the forum and read this thread...just yesterday I inserted a express card reader.
    Anyone know how to prevent this? Or just don't leave it in?
     
  7. ZAK248313 macrumors member

    Joined:
    Jan 23, 2006
    #7
    I had this same problem with mine.

    It awoke from sleep while still in my bag (for 2 hrs) and was literally too hot to touch. The fans were both cranking full speed. Not ideal.

    Took me a while to work out that even losing a bluetooth connection wakes it from sleep. Pretty annoying. Once that option is off- it sorted it.

    But- in saying that- I have the 24inch LED which I connect to my unibody (with lid closed, in the little space under the screen).

    If it goes into sleep mode I cant wake it with my keyboard or mouse- have to take it out from under the screen- and open the lid. Pretty annoying.

    They really should just program it that loss of bluetooth connection doesnt wake it.
     

Share This Page