Unibody MBP waking up and not connecting to wireless automatically

Discussion in 'MacBook Pro' started by James17, Feb 10, 2009.

  1. James17 macrumors 6502

    Joined:
    Dec 13, 2007
    #1
    I recently reinstalled MAC OS X on my unibody MBP. I've installed all the updates and it's been working fine until now. When it goes to sleep automatically I press a key and it wakes up then the Airport icon in the bar at the top of the desktop stays greyed out. I have to go in and manually connect to my router each time the machine wakes from sleep. I don't know what the problem is. Any help would be appreciated.
     
  2. drewsof07 macrumors 68000

    drewsof07

    Joined:
    Oct 30, 2006
    Location:
    Ohio
    #2
    Try going under System Preferences -> Network -> Airport -> "Advanced" and see if "Remember any network this computer has joined" has a checkmark, otherwise your computer will not automatically rejoin a network it was connected to. This should be the only box checked under this menu for what you're trying to do.

    Also, be sure to check that your preferred wireless network is in the #1 position on the list of "Preferred Networks" under the same "Advanced" settings window.
     
  3. James17 thread starter macrumors 6502

    Joined:
    Dec 13, 2007
    #3
    Thanks for the quick reply. The "Remember any network" option is the only option out of the three with a checkmark so that's ok. There is only one router in "Preferred Networks" which is my home one.
     
  4. drewsof07 macrumors 68000

    drewsof07

    Joined:
    Oct 30, 2006
    Location:
    Ohio
    #4
    Is your network password protected, or unprotected? It could be having trouble negotiating with your router, or being rejected entirely. Try deleting your network completely from the list, reconnecting, entering your password and be sure to click "remember in my keychain". see if that helps anything. If not, thats all the ideas I have right now. :eek:
     
  5. iBrody macrumors 6502

    Joined:
    Jun 11, 2008
    #5
    I have a similar problem with my MBP 15" Unibody using Leopard 10.5.6:

    I used to use D-Link DIR-635 wireless router with no issues, the network would connect automatically when waking from sleep.

    I upgraded to AirPort Express 2 months ago and noticed that I had to choose my network each time the MBP woke from sleep mode. The AirPort Express was sent back faulty for another issue and I decided to upgrade to the new dual-band Airport Extreme.

    However I still have the same sleep issue.

    The keychain has been cleared, the tickbox for 'remember this network' is checked under advance settings. I even set up a guest account to test waking up from sleep mode to no avail.

    I called Apple technical support and after 90 minutes on the phone, they too couldn't figure out what the problem was. They now want me to perform some kind of reset (without deleting the HDD, can't remember exactly what it was called - soz, my Apple tech knowledge is rubbish!).

    Before I go down this route, does anyone know if any other fixes that I can try? I am beginning to think that this is a hardware comapitibility issue rather than a software issue... but why would the MBP work flawlessly with a third party router and not an Apple router? Seems really strange to me.

    Anyway, any further tips would be much appreciated.
     
  6. DMC-12 macrumors 6502

    DMC-12

    Joined:
    May 16, 2007
    Location:
    Nashville, TN
    #6
    I'm having the same issue with my early 2008 MacBook Pro and a Belkin router. Also, it won't sleep on its own and the trackpad will not wake it from sleep.
     
  7. areusche macrumors regular

    areusche

    Joined:
    Jun 24, 2008
    #7
    I am having this problem as well. I am not able to connect to my SSID hidden, WPA encrypted network once I power on or wake.
     
  8. dukedvl macrumors member

    Joined:
    Aug 5, 2008
    #8
    I was having a similar problem. I found that if I went into System Preferences-->Network-->Join Other Network and added the network there, it would not find the network each time after waking.

    If I clicked on the Airport icon from the title bar, Joined Other Network, and added the network from there, it would remember the network and automatically connect after waking. Not sure why it worked this way but it did.

    I am on a MBP, AEBS using WPA2 and not broadcasting the SSID.
     
  9. iBrody macrumors 6502

    Joined:
    Jun 11, 2008
    #9
    Do you think that a fresh install of Leopard could rectify the sleep problem?
     
  10. avediswolf macrumors regular

    avediswolf

    Joined:
    Jul 23, 2008
    Location:
    Ohio
    #10
    This has seemed to cure alot of airpot issues:

    Have you moved the "System Preferences" icon from the application folder to the Utilities folder? Put it back.

    I had a problem where mine wouldn't auto connect. I posted it on the Apple discussion forums, and someone mentioned that, I thought... yeah.. the How did they know.. then moved it back, and things worked.

    If you didn't move that, I have no clue.
     
  11. iBrody macrumors 6502

    Joined:
    Jun 11, 2008
    #11
    Tried moving the folder and still no joy. Thanks for the tip anyway.

    It's weird, as I said before my network connects automatically using a D-Link router but not with an Airport Express or Extreme.

    Is it likely that Apple will replace my MBP if a fresh install of Leopard does not work? I cannot be without it for long as it's my only comp and this sleep issue is really annoying me now.

    I don't have Applecare but have only had the MBP since November 08.
     
  12. racker79 macrumors newbie

    Joined:
    Apr 7, 2009
    #12
    worked for me

    1. Switch off the wireless network
    2. delete Network in the Advanced menue of the wifi setup
    3. start the Application -> Utilities -> Keychain Access.app
    4. delete the password for you network
    5. rejoin the network

    worked for me good luck
     
  13. MacUser09ff macrumors newbie

    Joined:
    Apr 5, 2009
    #13
    Solved my Problem

    This solved my problem with my unibody MacBook connecting to a Netgear Router. Thank you avediswolf! This was becoming increasingly annoying.

    MacUser09ff
     

Share This Page