Unibody Nvidia + Photoshop CS4 OpenGL bug?

Discussion in 'Mac Apps and Mac App Store' started by bay2sacto, Mar 1, 2009.

  1. bay2sacto macrumors member

    Joined:
    Nov 6, 2008
    #1
    I am experiencing a particular bug in Photoshop CS4 Extended which is related to the OpenGL GPU acceleration which is very dependent on the video driver. The particular bug I'm seeing is when I free transform a object/layer or perform a transform selection the transformed object/layer/selection is off by a pixel and that pixel is semi-transparent with whatever is being transformed.

    Can anybody with both a unibody and Photoshop CS4 test this on their system to see if its really an issue with the driver or if it is something with my Photoshop installation?

    Here's what I do to test. 1. creat a new doc at any size/ppi. 2. drag out a selection and fill with a solid color. 3. free transform object/selection. 4. zoom in on transformed object and look at the edges to see if there is this feathered/semi-transparent edge.

    I haven't tested in bootcamp since I don't have a Win version of CS4.

    Thanks.
     
  2. Brien macrumors 68020

    Brien

    Joined:
    Aug 11, 2008
    #2
    I tried duplicating this a few times, and sorry to say, I couldn't.

    15" MBP and CS4, so it's got to be something else?
     
  3. bay2sacto thread starter macrumors member

    Joined:
    Nov 6, 2008
    #3
    hmm...I tried resetting the preferences and still have the same issue. I'm using the discrete 9600 GPU. Don't know if I need to try a re-install of CS4. I've alrey upgraded to PS 11.01. Quite annoying! I also applied the January 09 Nvidia update so i don't know if that has anything to do with this.
     
  4. bay2sacto thread starter macrumors member

    Joined:
    Nov 6, 2008
    #4
    Here are screenshots:

    [​IMG]

    [​IMG]

    [​IMG]

    [​IMG]

    I reset Photoshop preferences. Then reinstalled Photoshop which seemed to make things kinda better. I only get the distortion when free transforming and not transforming a selection.
     
  5. 55orangeave macrumors member

    55orangeave

    Joined:
    Jan 29, 2009
    Location:
    AB, Canada
    #5
    I know this is not exactly related to the beginning issue. But when I try to install CS4 the program installs, when I go to Launch I see dull PS icon that says this architecture doesn't support this program.????? Has anyone else seen this problem before.

    I have a 2.0 unibody macbook. What gives here

    Thanks for any support.
     
  6. bay2sacto thread starter macrumors member

    Joined:
    Nov 6, 2008
    #6
    Hello,

    I have seemed to excise the transform demon. I did a full uninstall/reinstall of CS4. I was getting weird issues with Adobe Update not correctly applying updates and not showing the various apps as have being updated so I figured a reinstall was needed. After testing Photoshop after the reinstall the free transform/transform selection bug I was seeing is gone. Yay!

    So I think the lesson I learned from this whole ordeal is: DON'T EVER RENAME ADOBE APPLICATION FOLDERS!
     

Share This Page