Uninstall Bootcamp, What's left behind?

Discussion in 'Windows, Linux & Others on the Mac' started by RKnight, Nov 9, 2007.

  1. RKnight macrumors newbie

    Joined:
    Feb 17, 2007
    #1
    Okay I know this may sound weird but I'm wondering if anyone knows an answer to this. About 8 months ago I used the Boot Camp beta to run WinXP on my MacBook Pro 2,2. I ended up deciding I didn't want it and used the Boot Camp Assistant to remove it. All ways fine. I have since did an Erase and Install of Leopard, all is still fine. But I was messing around with rEFIt (never installing it) but I ran its Partition Inspector and got this:

    Current GPT partition table:
    # Start LBA End LBA Type
    1 40 409639 EFI System (FAT)
    2 409640 312319623 Mac OS X HFS+

    Current MBR partition table:
    # A Start LBA End LBA Type
    1 1 312581800 ee EFI Protective

    MBR contents:
    Boot Code: Unknown, but bootable

    Partition at LBA 40:
    Boot Code: None (Non-system disk message)
    File System: FAT32
    Listed in GPT as partition 1, type EFI System (FAT)

    Partition at LBA 409640:
    Boot Code: None
    File System: HFS Extended (HFS+)
    Listed in GPT as partition 2, type Mac OS X HFS+


    Whats up with these FAT and FAT32 partitions? Was something left over from Boot Camp and I've never realized it? I ran diskutil list in Terminal and got this:

    /dev/disk0
    #: TYPE NAME SIZE IDENTIFIER
    0: GUID_partition_scheme *149.1 Gi disk0
    1: EFI 200.0 Mi disk0s1
    2: Apple_HFS MacBook Pro 148.7 Gi disk0s2

    /dev/disk1
    #: TYPE NAME SIZE IDENTIFIER
    0: Apple_partition_scheme *297.5 Gi disk1
    1: Apple_partition_map 31.5 Ki disk1s1
    2: Apple_HFS rob 297.5 Gi disk1s2


    I don't see anything there mentioning FAT or FAT32 but EFI is there. By the way /dev/disk1 is my File Vault Disk Image, I know that.

    If I run rEFIT on a thumb drive, by holding down option on boot, my Mac of course asks to boot from my internal drive or the thumb drive running rEFIt, once rEFIt is loaded it asks to boot into my OSX partition or a Windows partition.... huh!? I thought it was gone! If I run it I get a usual looking white text on black screen saying there is nothing to boot to. So how is there any windows-type partition still there?

    So does anyone know? Is something left behind from those partitions that Boot Camp made that not even an Erase and Install of OS X Leopard got rid of? I know this is a little OSD of me, but I'm dying to know. And would love to know how to remove all traces of it. Thanks!
     
  2. Bill Gates macrumors 68020

    Bill Gates

    Joined:
    Jun 21, 2006
    Location:
    127.0.0.1
    #2
    I don't see anything wrong with what you've got right now. The 200MB EFI partition is formatted as FAT32, and all intel macs have that partition. The only other partition I see listed is the OS X HFS+ formatted partition, which is also normal. Diskutil doesn't show my hybrid GPT/MBR partition scheme when I do a list, only the GPT table, so it's possible that you still have an MBR table on disk0 and that it isn't normally shown with the list command. REFIt may be looking at the MBR table when it gives you the option to boot into Windows, or it may be something different altogether. My advice is to just forget about it.
     
  3. harborsparrow macrumors newbie

    Joined:
    Apr 13, 2008
    #3
    it's the "Protective MBR" that's showing up

    Please see http://www.microsoft.com/whdc/device/storage/GPT_FAQ.mspx
    item 9

    You have a GTP disk, and it has a "fake" MBR (called a protective MBR) on there which makes it look like there's a huge unidentifiable partition present (but obscures to you that there is really a GTP partition present).

    The "fake" MBR keeps older utilities from "accidentally" wiping out the GTP partition (where you Mac OS is).

    I think.
     
  4. qubex macrumors 6502

    qubex

    Joined:
    May 12, 2004
    Location:
    045°042'21.99"N, 009°005'056.57"E
    #4
    Are you sure?

    I tried Boot Camp today, and decided it wasn't for me.

    After I removed the Windows partition using Boot Camp, this little 200MB partition disk0s1 was left behind.

    I hadn't ever noticed it before... are we absolutely sure it was always there?
     

Share This Page