Uninstall Xbox 360 Controller Driver?

Discussion in 'Mac Apps and Mac App Store' started by mahger, Mar 4, 2008.

  1. mahger macrumors member

    Sep 14, 2007
    I installed the 3rd party xbox 360 controller driver for the mac, and now I need to uninstall it. I got Guitar Hero 3, and my X-plorer wont work with it. Ive heard that the driver I have installed can cause this, and I have rules out everything else, so it must be this driver. Since the driver doesnt install itself in the applications folder, I tried removing the preference pane and taking it out of the startup folder, but my guitar still works in programs like frets on fire, and still doesnt work in Guitar Hero. I also emailed the developer on how to uninstall it, but I have not received a response.
  2. ultimateceej macrumors regular


    Jul 24, 2007
    Did you just control click and remove it from the Preference Pane or did you actually delete the file? It's located in /<hard Drive name>/Library/Preference Panes.
  3. mahger thread starter macrumors member

    Sep 14, 2007
  4. ultimateceej macrumors regular


    Jul 24, 2007
    And it is still interfering guitar hero or no?
  5. mahger thread starter macrumors member

    Sep 14, 2007
  6. tonyeck macrumors 6502


    Sep 3, 2004
    Las Vegas, NV
  7. maxly23 macrumors newbie

    Apr 5, 2008
    Hey, i was having problems with this as well.
    I'm not sure which driver you're using, but I was able to fix my problem by removing the file 360Controller.kext from the /system/library/extentions folder.
    Reboot, and it should work.
    Again, this was the drivers downloaded from tattiebogle.net, might not work for everyone
    Hope that helps
  8. KennyDolfan® macrumors newbie

    Jul 25, 2006
    I'm having the same exact problem.
    I deleted EVERY trace of that 360 controller thing from tattiebogie.net
    and it ended up erasing my Guitar hero 3 history,Plus my X-plorer controller STILL does not work.So i erased Guitar hero 3 from my Mac..and reinstalled it...still refuses to work.
  9. okboy macrumors regular

    Oct 9, 2010
    I donated to the developer and asked him how to uninstall. That was like a year ago and no reply and no info on hist site how to unistall. Real bugger.
  10. floxy31, Sep 15, 2012
    Last edited: Sep 15, 2012

    floxy31 macrumors newbie

    Sep 15, 2012
    I installed this driver on my retina macbook pro with Mountain Lion and the result is that my mbp turns off in 12 seconds ... usually turned off in 3 seconds ... I really don't know what to do :(
    I tried to uninstalled it: Library/PreferencePanes, I deleted the xbox360controller file. In "Preference" there is not the icon but the macbook still takes 12 seconds to turn off ...
  11. actionscripted macrumors newbie

    Jan 4, 2013
    Note: this information was put together January 4th, 2013 (2013-01-04) and it's possible the author of the driver may have changed things since.

    How to uninstall the Xbox 360 controller driver from TattieBogle (http://tattiebogle.net/index.php/ProjectRoot/Xbox360Controller/OsxDriver):

    1. Remove the following files:
      1. /Library/PreferencePanes/Pref360Control.prefPane
      2. /Library/StartupItems/360ControlDaemon
      3. /System/Library/Extensions/360Controller.kext
      4. /System/Library/Extensions/Wireless360Controller.kext
      5. /System/Library/Extensions/WirelessGamingReceiver.kext
    2. Restart your computer
    3. Done!

    I've gone through every bit of this driver package and cannot find anything to worry about beyond these files. All the PKG installer is doing is copying these from the PKG to places on your system. While a PKG can do things that aren't necessarily reported in lsbom or pkginfo, TattieBogle's driver installer isn't. Once you've removed the files above, you're all set.

    To view exactly what the PKG installed:

    • Open Applications > Utilities > Terminal.app
    • Run
      pkgutil --pkgs | grep 360
      to find the id used by the installer, likely
    • Run
      pkgutil --files com.mice.pkg.Xbox360controller
      to view a list of files installed by the program

    You can also browse the downloaded PKG as a folder using either Terminal or right-clicking it and selecting "Show Package Contents".
  12. Dismal macrumors newbie

    Jan 13, 2013

    I'm stuck with this new version of the driver that doesn't work. (the latest version available on tattieboogie.net)
    I did exactly what you said by deleting those files because I wanted to install an older version of the Xbox controller driver that actualy works.
    Unhopefully, it didn't work, when i try to install another version it says that it's impossible 'cause there'is still another version installed.

    Do you have any clue?

  13. JasonRitchie macrumors newbie

    Jan 20, 2013
    So once the files are removed you may have to tell your Mac to "forget" about that package. I would imagine that a real uninstall procedure would remove the files listed with this command:
    pkgutil --files com.mice.pkg.Xbox360controller
    And then it would remove the package itself with this command:
    pkgutil --forget com.mice.pkg.Xbox360controller
  14. d4rkwolf macrumors newbie

    Jan 28, 2013
    It's not allowing me to "forget" the package :( This is the Terminal message I am getting when I follow those steps:


    What can I do now?
  15. sidjug macrumors newbie

    Feb 7, 2013
    I have the exact same problem. I can't get my xplorer guitar to work with my mac (running snow leopard 10.6.8)
    I've installed the lastest version of the drivers (downloaded from tattiebogle), but the green light on the guitar keeps blinking and the guitar isn't recognized as a controller.
    This is where I got the closest to the solution: https://discussions.apple.com/thread/2134285?start=0&tstart=0
    but unfortunately the download link has expired and probably it was referred to an older version of the driver.
    So here we are. How do I get the ********** guitar speak to my mac ? :D
    Thanks in advance for any help
  16. hulster macrumors newbie

    Mar 1, 2013
    This looks even being from Jan already a bit outdated. I am runing 10.8.2 I checked the package content by the "pkgutil --file" and the file/folder list looks to be the following currently:

    1. /Library/Application Support/MICE/360Daemon
    2. /Library/LaunchDaemons/com.mice.360Daemon.plist
    3. /Library/PreferencePanes/Pref360Control.prefPane
    4. /System/Library/Extensions/360Controller.kext
    5. /System/Library/Extensions/Wireless360Controller.kext
    6. /System/Library/Extensions/WirelessGamingReceiver.kext
    Especially daemon related stuff is different
  17. hulster macrumors newbie

    Mar 1, 2013
    After opening terminal - did you execute command "sudo su -"?
    Such operations needs root as usually protected and only executed by subroutines.
    BUT if you were not aware so far - be careful. There is not any further layer protecting your system - except TimeMachine. ;-)
    Executed as root the "forgot" works for me.


    The manual uninstall works so far - for me.
    Originally it was worse for me. After installing the driver the controller was not recognized without having it plugged in BEFORE but. Any unplug when system was up caused system crash.
    BUT during installation (as by the instructions) I had already the controller plugged in. This was the recommendation if you like to use the controller directly without reboot. I will give it another try, with a clean installation. If it doesn't work it must be someting ML related, as comments show satisfaction for all earlier OS versions.
  18. hulster macrumors newbie

    Mar 1, 2013
    So - clean install of the last version 0.12 (same as used before) works now. Clean means - without controller plugged in and reboot after.
    After reboot controller will be properly recognized when plugged in and can be unplugged anytime without system crash.
    As most of you interested just into remove it this somehow confirms my folder/file list works incl. pkg forget. So hope this helps for you as well.
    As I used 10.8.2 this may defer for other OS version.
    So I clearly recommend to use

    pkgutil --files com.mice.pkg.Xbox360controller

    to verify location of files and folders.

    Hope this helps.
  19. pekapa macrumors newbie

    Sep 14, 2012
    Not working for me...

    I completely uninstall and forgot the package, restarted, installed the newest driver (controller unplugged), restarted again and the controller is not identified and an unplug causes the system to crash... =/

    I'm running a Retina MBP Mid2012 with Mountain Lion, 10.8.2

    Any suggestions? Should I try an older version of the driver (0.11 perhaps) or does anyone knows other drivers for the 360 controller?
  20. hulster macrumors newbie

    Mar 1, 2013
    Did you check for different folder list I presented? Did you doublecheck after you uninstalled? If all files really removed and package forgot, there should anymore an issue with the old installation.
    Still there is an option usb device on your MBP has some differences in driver. From my perspective - very unlikely.
  21. pekapa macrumors newbie

    Sep 14, 2012
    Just tried everything again... double checking every step and restarting between all of them...

    If I plug the controller with the system running it will work on the first 3s and than stop. Unplug causes the system to crash.

    If I plug with the computer off and than turn it on the controller works and if I unplug it won't crash... Didn't tried to plug again to see if works or not (will do it latter).

    I also tried both USB ports on the mac...
    I'll keep trying tomorrow... enough crashes for one day... xP
  22. hulster macrumors newbie

    Mar 1, 2013
    This sounds to me as if there are still not all settings/files deleted.
    I would propose you check with

    pkgutil --files com.mice.pkg.Xbox360controller

    specifically for YOUR system and delete all files/folders listed.
    Did you use "rm -r" to delete the files/folders? Did you doublecheck the files/folders not existing anymore? Did you empty trash?
    You may like to doublecheck with "Find Any File" while this tool really find any file in opposite to Spotlight. ;-)
  23. pekapa macrumors newbie

    Sep 14, 2012
    Yep, I opened 2 terminal, ran pkgutil in one and removed all the files and folders with sudo rm and sudo rm -rf
    I also checked everything with ls on the directory they were...
    I even forgot the package with sudo just to make sure... I ran pkgutil --pkgs | grep 360 to check and it was indeed forgotten...
  24. hulster macrumors newbie

    Mar 1, 2013
    That all looks sufficient. I stuck here as you.
    Only I didn't see you doublecheck with a search tool like "Find Any File", as I recommended.
  25. pekapa macrumors newbie

    Sep 14, 2012
    Tried everything again, checked with Find Any File this time... same thing... =
    Updated to 10.8.3 and tried again... No differences...
    I just need to get used to reboot every time I want to play... xP

Share This Page

24 March 4, 2008