Uninstalling/Salvaging Firefox

Discussion in 'Mac Apps and Mac App Store' started by silvermike, Dec 13, 2008.

  1. silvermike macrumors newbie

    Joined:
    Mar 12, 2005
    #1
    Spontaneously, Firefox has started crashing on me. And almost instantly - it opens, asks if i want to restore the old tabs, opens to the default page, then shuts down.

    I've tried the usual run of solutions: I restarted, I deleted and reinstalled firefox, I deleted my preferences and reinstalled, I deleted everything with the word 'firefox' or 'mozilla' from my hard drive, and I tried both upgrading to the latest beta and downgrading a version. Same problem every time.

    So I'm left with this: a.) Does anyone know how I might be able to rescue 'fox and get it working again? I keep thinking that maybe I missed some key file besides what's in my application support folder.

    And b.) I did backup my profile in an attempt to save my bookmarks and such. It's locked away safely in a .zip file so I don't think it could possibly be interfering. But I can't import the bookmarks directly into safari because the backups are all saved as .json files instead of .html. Any thoughts? The easy way would be to open up firefox and do it, of course, but that's now impossible.

    Oh, and here's the crash report. I'm running on a iMac G5:

    Add-ons: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}:0.7.5.5,{972ce4c6-7e08-4474-a285-3208198ce6fd}:3.0.4
    BuildID: 2008102920
    CrashTime: 1229169868
    InstallTime: 1226700692
    ProductName: Firefox
    SecondsSinceLastCrash: 34445
    StartupTime: 1229169836
    Theme: classic/1.0
    URL: file://localhost/Users/Mike/bookmarks.html
    UserID: c88f3f8f-6c08-4d36-972e-86259225b7a1
    Vendor: Mozilla
    Version: 3.0.4

    This report also contains technical information about the state of the application when it crashed.
     
  2. Gray-Wolf macrumors 68030

    Gray-Wolf

    Joined:
    Apr 19, 2008
    Location:
    Pandora, Home Tree
    #2
    As an experiment, remove it completely. then do a "repair Permissions" deal, then download a fresh copy and install.
     
  3. silvermike thread starter macrumors newbie

    Joined:
    Mar 12, 2005
    #3
    Permissions was a good idea; unfortunately, the result is identical.
     
  4. trainguy77 macrumors 68040

    Joined:
    Nov 13, 2003
    #4
    delete the preference files from both your user library and the root library. As well as any application support in both locations. Give that a shot.
     
  5. silvermike thread starter macrumors newbie

    Joined:
    Mar 12, 2005
    #5
    Tried clearing root preferences - there was some mozilla stuff. No luck.

    I'll note I've downloaded Flock to try, and it has the same probelm. Camino and Safari are fine.
     
  6. QueenZ macrumors 6502

    QueenZ

    Joined:
    Oct 26, 2008
    #6
    Try removing all addons or install it somewhere else
     

Share This Page